[Rd] Rcmd check for Windows fails (PR#7369)

Peter Dalgaard p.dalgaard at biostat.ku.dk
Sun Nov 14 21:20:50 CET 2004

harald.weedon-fekjar at medisin.uio.no writes:

> "Rcmd check" seems to fail without any good error report if the package contains
> a certain amount of R code and is run from a directory contain a space in the
> name (strange, but ...very annoying as I tried to include/exclude new parts many
> times).
> For error report and the source that fail, see:
> http://folk.uio.no/hfe/pub/slettes-dato/2005-12/addreg-check-log.txt
> http://folk.uio.no/hfe/pub/slettes-dato/2005-12/addreg.zip
> Feedback would be welcommed.

If you're quick you could check and tell us whether this is fixed in
2.0.1, see


In particular, this stuff from the CHANGES file could be relevant:

"We have increased the chances that installing a source package from
an explicit path with spaces in will work, so e.g.

    R CMD INSTALL "/Documents and Settings/myname/Source Files/mypkg"

will probably work -- it is still not recommended.  You can also
get away with backslashes here, but forward slashes are safer."

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)             FAX: (+45) 35327907

More information about the R-devel mailing list