[Rd] wishlist: better error message in R CMD check

Gabor Grothendieck ggrothendieck at myway.com
Sat Nov 6 16:07:09 CET 2004

Liaw, Andy <andy_liaw <at> merck.com> writes:

> Gabor,
> I guess is that you did not try to run R CMD INSTALL before R CMD check.  R
> CMD check will try to install the package first (in pkg.Rcheck), and only if
> that's successful would checks be done.
> The installation process will concatenate all R files in R/ to a single file
> and essentially source() that in upon package loading.  That's where you
> would see the syntax error.  I believe the recommended way is to install the
> package and play with that a bit first, before doing R CMD check.  You'd
> find some problems are much easier to find that way (e.g., errors in

Thanks. Unfortunately if I run R CMD INSTALL
I get this:

  preparing package zoo for lazy loading
Error in tools:::.read_description(file) :
        file '/DESCRIPTION' does not exist
Execution halted
make: *** [lazyload] Error 1
*** Installation of zoo failed ***

Removing 'C:/PROGRA~1/R/RW2001~1/library/zoo'

I get a similar message if I run R CMD build --binary .

The DESCRIPTION file definitely exists so I assume it to
be something else.  

If I run run R CMD check then it crashes (that is,
I get a popup asking me if I want to send a bug report to 
Microsoft) at various points depending on which example
code in the .Rd files I comment out).  If I comment out
enough to let it run past them all then I get the following
(where I have added the dots at the beginning of each
line in this post to circumvent's gmane's top posting filter):

.> ### * runmean
.> flush(stderr()); flush(stdout())
.> ### Name: runmean
.> ### Title: Running Means/Maximums/Medians
.> ### Aliases: runmean runmax runmed
.> ### Keywords: ts
.> ### ** Examples
.> # x.date <- as.POSIXct(paste("2003-", rep(1:4, 4:1), "-", sample(1:28, 10, 
replace = TRUE), sep =
.> # x <- zoo(rnorm(12), x.date)
.> # runmean(x, 5)
.> # runmax(x, 5)
.> # runmed(x, 5)
.> cleanEx(); ..nameEx <- "value"

I assume its the cleanEx line that is the problem but that is
not one my lines.  I would have tried it with an earlier
version of R but I don't want to overwrite the version
of the package I have installed on R 2.0.0 since then I will
be unable to proceed at all.

I am using Windows XP and R 2.0.1beta .

More information about the R-devel mailing list