[Rd] Several libraries won't load with (PR#6927)

Uwe Ligges ligges at statistik.uni-dortmund.de
Mon May 31 18:21:30 CEST 2004

rmh at temple.edu wrote:

> Thank you both.
> 1. It looks like part of the problem is indeed that the packages in the
> patched version for Windows aren't coordinated with the libraries.
> rw1090
> library(MASS)  ## works
> rw1090pat
> library(MASS)  ## doesn't work
> library(MASS, lib.loc="c:/progra~1/R/rw1090/library")  ## works

[not to r-bugs, since none of the former e-mails of this thread belongs 


packages are coordinated! Note that *recommended* (not base!) packages 
are included in release versions only, hence you have to install them 
separately in patched/devel versions of R!
   install.packages("VR") should do the trick ...

> 2. This doesn't explain why the freshly downloaded Hmisc and multcomp
> packages didn't load.  I now think that is due to a documentation problem.


 > I am using Windows.  All the documentation for installing
> packages is Unix-centric.  

No. There is the R Installation and Administration manual (mentioning 
details on the Windows version),
?install.packages, ?INSTALL and there is the R for Windows FAQ (the 
latter two are for sure very Windows-centric).

 > Your emails were also Unix-centric.

No. What was Unix-centric in my e-mail, please? I am using Windows 
almost all the time ....

> After wandering through documentation I initially unzipped the
> downloaded files, for example,
>     Windows binary: Hmisc_2.0-9.zip
> into the rw1090pat/library.  This unpacked correctly but did not load.

Unzipping should work as well, but maybe your files were still locked at 
that time?

> After your emails, I tried Rgui and found the "Packages/Install
> package(s) from local zip files..." menu item.  I did this and now it
> works.  The unzipped files in library/Hmisc/* are identical when I did
> a manual unzip and when I did the menu installation.

In that case I guess you haven't detached and loaded the package again 
when you tried at first?
install.packages() hasn't much more side-effect (just updating some 
indexes which are NOT required to load the package).

> Suggestion: please add a paragraph to the top of the Contributed Packages
> page that says, "Windows users---including ESS Windows users---should install
> the downloaded zip file with the Packages menu item from Rgui".

Hmm. The first paragraph says:

Please type help(INSTALL) or help(install.packages) in R for information 
on how to install packages from this directory. The manual R 
Installation and Administration (also contained in the R base sources) 
explains the process in detail.

And these documents tell to use install.packages(). So no need to add 
anything from my point of view. There is also a Section 3.1 in the R for 
Windows FAQ....

> 3. Martin's comment
>    > Are you running another version of R simultaneously? 
>    > IIRC, Windoze has the nice feature to sometimes lock files when 
>    > it shouldn't.   
> isn't the problem.  I have two Rgui and one iESS [R] running and all three
> have loaded the Hmisc and multcomp packages.

Maybe, but after you have loaded the package, you cannot overwrite it, 
because the dll files are locked (yes, dlls are locked when in use under 
Windows). So Martin's analysis was correct.
Therefore you have to detach those packages you want to re-install or 
update (and also close all chm documentation - or even better close 
corresponding instances of R).


> Rich
> ______________________________________________
> R-devel at stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list