[Rd] Depends: R(>= ?)

Paul Gilbert pgilbert@bank-banque-canada.ca
Mon, 12 Jun 2000 12:08:10 -0400

I am just working through my set of tests for R 1.1.0 and everything
seems to be going fairly well other than a couple of bugs already
reported and fixed.

I previously specified Depends: R(>= 1.0.1). I have been making small
changes to my own code and since I have been doing this with R 1.0.1  I
am fairly sure everything still works with it, but I don't intend to
test this as carefully as R 1.1.0. Should I change "Depends" to indicate

Now I realize what the "safest" answer would be, but I can see this will
be an ongoing problem and the implication of changing each time is that
my packages always depend on the latest version of R. I can see the
posssibilty of testing 1.0.1 and 1.1.0, but when R 1.99 arrives I don't
see any possibility for testing every version since R 1.0.1. Should
"Depends" indicate what is "known to be at least necessary" or should it
be something stronger than that?

Paul Gilbert

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch