[ESS] Startup error on XEmacs with ESS 2.5.11 (error "Stack overflow in regexp matcher")

john.gavin at ubs.com john.gavin at ubs.com
Thu Mar 2 18:18:29 CET 2006

Hi Rodney,

I tried to upgrade from XEmacs 21.4.6 to 21.4.19, as you sugget,
but that didnt change anything.

However, I also decided to start looking for the problem
all over again (with XEmacs 21.4.19 and ESS 5.2.12). 
Eventually, I found the problem to be the line
'(setq default-directory "s:/qrms/stats/r")' in my init.el
which appears just after loading ess-site.el.

(require 'executable)
(load "C:/etc/XEmacs/xemacs-packages/lisp/ess/lisp/ess-site.el")
(setq default-directory "s:/qrms/stats/r") 

Commenting out or moving the line '(setq default-directory "s:/qrms/stats/r")'
to the end of my init.el file works.
A far as I can remember this line '(setq default-directory "s:/qrms/stats/r")'
has been in my init.el file for ages and in that position in the file.
So I am no wiser as to what caused this problem
but at least I can start XEmacs again with any errors.

Thanks for your time.



John Gavin <john.gavin at ubs.com>,
Quantitative Risk Control,
UBS Investment Bank, 6th floor, 
100 Liverpool St., London EC2M 2RH, UK.
Phone +44 (0) 207 567 4289
Fax   +44 (0) 207 568 5352

> -----Original Message-----
> From: Rodney Sparapani [mailto:rsparapa at mcw.edu]
> Sent: 02 March 2006 15:08
> To: ess-help at stat.math.ethz.ch
> Cc: Gavin, John
> Subject: Re: [ESS] Startup error on XEmacs with ESS 2.5.11 
> (error "Stack
> overflow in regexp matcher")
> Hi John:
> I have no idea what the problem is with 5.2.11.  One thought 
> is that XEmacs 21.4.6
> is going old and you should consider 21.4.19.  There are alot 
> of bug-fixes that you
> are missing out on.  If that doesn't help, the error message 
> from 5.2.12 seems to
> imply that your font-lock was either not called for or 
> broken.  What happens if you
> force it with (require 'font-lock) before loading ESS?
> Rodney
> ----
> Hi,
> I am on XEmacs 21.4.6 and ESS 5.2.11.
> This morning when I fire up XEmacs, I encounter an error
> "(1) (initialization/error) An error has occurred while 
> loading p:\.xemacs\init.el:
> Stack overflow in regexp matcher"
> Switching on the -debug-init option 
> I get the more detailed error message shown below.
> I tried to upgrade to 5.2.12 but that seems to produce a different
> error message (again see below for details).
> The only thing that has happened to my pc is that I was upgraded to 
> Office 2003 last night but I dont think that should make a 
> difference, should it?
> Fiddling with my init.el file the error is caused when I 
> start R with the line "(R)".
> The same error occurs if I try to start R manually within XEmacs.
> I would like to address the 5.2.11 error (Stack overflow in 
> regexp matcher)
> as this is the version of ESS that was working correctly previously.
> What might I try to address this, please?
> Regards,
> John.

Visit our website at http://www.ubs.com

This message contains confidential information and is intend...{{dropped}}

More information about the ESS-help mailing list