[ESS] Startup error on XEmacs with ESS 2.5.11 (error "Stack overflow in regexp matcher")

Rodney Sparapani rsparapa at mcw.edu
Thu Mar 2 16:07:48 CET 2006

Hi John:

I have no idea what the problem is with 5.2.11.  One thought is that XEmacs 21.4.6
is going old and you should consider 21.4.19.  There are alot of bug-fixes that you
are missing out on.  If that doesn't help, the error message from 5.2.12 seems to
imply that your font-lock was either not called for or broken.  What happens if you
force it with (require 'font-lock) before loading ESS?


I am on XEmacs 21.4.6 and ESS 5.2.11.
This morning when I fire up XEmacs, I encounter an error

"(1) (initialization/error) An error has occurred while loading p:\.xemacs\init.el:
Stack overflow in regexp matcher"

Switching on the -debug-init option 
I get the more detailed error message shown below.

I tried to upgrade to 5.2.12 but that seems to produce a different
error message (again see below for details).

The only thing that has happened to my pc is that I was upgraded to 
Office 2003 last night but I dont think that should make a difference, should it?

Fiddling with my init.el file the error is caused when I start R with the line "(R)".
The same error occurs if I try to start R manually within XEmacs.

I would like to address the 5.2.11 error (Stack overflow in regexp matcher)
as this is the version of ESS that was working correctly previously.
What might I try to address this, please?



With ESS 5.2.11 (and the -debug-init option) the error is:

Signaling: (error "Stack overflow in regexp matcher")
  re-search-backward("^[ 	]*\\([^#\n].*\\)[ 	]*$" nil t)
  (let* ((symbol-string ...) (switches-symbol ...) (switches ...) (buf-name-str ...)) (ess-write-to-dribble-buffer (format "(ess-multi 0):  


  (let* ((r-always-arg ...) (r-start-args ...)) (if ess-microsoft-p (setq default-process-coding-system ...)) (inferior-ess r-start-args) (ess-write-to-dribble-buffer (format "(R): inferior-ess-language-start=%s\n" inferior-ess-language-start)) (if inferior-ess-language-start (ess-eval-linewise inferior-ess-language-start)))
  load-internal("p:\\.xemacs\\init.el" t t t undecided)
  load("p:\\.xemacs\\init.el" t t t)

Inside XEmacs my ESS window reads

[ess-site.el]: ess-customize-alist=nil 
[ess-site.el _2_]: ess-customize-alist=nil 
(R): ess-rterm-versions-create making M-x defuns for 
(R): ess-dialect=nil, buf=*scratch*, start-arg=nil
(inferior-ess 0): ess-start-args=--ess   
ess-setq-vars-default 0: ess-language=Initial, -dialect=nil, buf=nil, comint..echoes=nil, comint..sender=comint-simple-send
ess-setq-vars-default 1: ess-language=S, -dialect=R, buf=nil, comint..echoes=nil, comint..sender=comint-simple-send
(inf-ess 1): lang=S, dialect=R, tmp-dialect=R, buf=*scratch*
(inf-ess 1.1): procname=R temp-dialect=R, buf-name=*R* 
(inferior-ess) Method #3 start=s:/qrms/stats/r buf=*R*
(ess-setq-vars-LOCAL): language=S, dialect=R, buf=nil, comint..echoes=nil, comint..sender=comint-simple-send
(inf-ess 2.1): ess-language=S, ess-dialect=R buf=*R* 
(inf-ess 2.2): start args = --ess  , inf-ess-start-args=--ess   
(inf-ess finish [S(R), Rterm(nil,nil)]
(ess-multi 0):  inf-ess-start-args=--ess  , comint-..echoes=nil
(i-ess 1): buf=*R*, lang=S, comint..echo=nil, comint..sender=comint-simple-send,
(i-ess 2): buf=*R*, lang=S, comint..echo=t, comint..sender=inferior-R-input-sender,
(ess-setq-vars-LOCAL): language=S, dialect=R, buf=nil, comint..echoes=t, comint..sender=inferior-R-input-sender
(i-ess 3): curr-buf=*R*, comint..echo=t, comint..sender=inferior-R-input-sender,
(ess-multi post inf-ess: start-args=--ess  , comint-echoes=t

With ESS 5.2.12 (and the -debug-init option) the error is:

Signaling: (void-variable font-lock-constant-face)
  (cons "^NOTE: .*$" font-lock-constant-face)
  (list (cons "^NOTE: .*$" font-lock-constant-face) (cons "^ERROR: .*$" font-lock-keyword-face) (cons "^WARNING: .*$" font-lock-function-name-face) 


(cons "\\<call[ 	]+[a-z_][a-z_0-9]*[ 	]*(" font-lock-function-name-face) (cons ... font-lock-function-name-face)))
  (defvar SAS-mode-font-lock-keywords (if ess-sas-run-make-regexp (list ... ... ... ... ... ... ... ... ... ... ... ...) (list ... ... ... ... ... ... ... ... ... ... ... ... ... ... ... ... ... ...)) "Font Lock regexs for SAS.")
  load-internal("essl-sas" nil t nil undecided)
  load("essl-sas" nil t nil)
  load-internal("essd-sas" nil t nil undecided)
  load("essd-sas" nil t nil)
  load-internal("C:/Program Files/XEmacs/xemacs-packages/lisp/ess/lisp/ess-site.el" nil nil nil undecided)
  load("C:/Program Files/XEmacs/xemacs-packages/lisp/ess/lisp/ess-site.el")
  load-internal("p:\\.xemacs\\init.el" t t t undecided)
  load("p:\\.xemacs\\init.el" t t t)

Visit our website at http://www.ubs.com

This message contains confidential information and is intend...{{dropped}}


More information about the ESS-help mailing list