[ESS] RGUI not responding

Richard M. Heiberger rmh at temple.edu
Thu Mar 31 23:12:03 CEST 2005

>One thing I've 
>noticed is that if I run xemacs from an icon in c:\documents and 
>settings\administrator\desktop\programs\ (my default place for things 
>I run often) and if I then run esc-x shell I get two new empty 
>subdirectories created off that directory, one named .exe, the other 
>named -i.  

Another argument against file names with embedded blanks.

Actually it is most likely the problem is not the location of the icon.
It is more likely that you didn't change the value of the 'Start in:' field
to something sensible.  I use c:\HOME\rmh in that field.  I also set the HOME
environment variable to c:\HOME\rmh to get approximately Unix-like behavior.
I never write "Program Files", I always write "progra~1" which is the official
microsoft 8.3 version of the name.  You can get the 8.3 names from MSDOS XP "dir/x",
from emacs w32-short-file-name and from xemacs win32-short-file-name.

If R always starts with the new xemacs, then something is wrong with the defaults
in the new xemacs.  One of the xemacs users on the list will have to
respond to that.  Again, try the xemacs equivalent of
   emacs -q --no-site-file
(and spell it correctly for xemacs, these are gnu emacs values).


More information about the ESS-help mailing list