[ESS] RGUI not responding

Chris Evans chris at psyctc.org
Thu Mar 31 22:39:59 CEST 2005

On 31 Mar 2005 at 21:54, A.J. Rossini wrote:

> I'm trying to find time to think about it, but not yet.  It's a weird
> report.  I don't think you are wasting time, just some of us who want
> to fix it are a bit busy.

Yes, I regretted sending that as soon as I did and I think that's a 
very generous response under the circumstances.  Apologies all: I've 
had a sh*tty few months with my beloved FLOSS s'ware giving me 
problems etc. etc. but enough of my whingeing ...

It remains weird.  I deleted xemacs completely (which I do rather 
like and have become used to) using its uninstaller.  It took two 
goes but uninstalled it.  I then downloaded the windows native 
installer, ran it again, got xemacs 21.4 patch 3 with ESS 5.2.3.  
That does what it's always done for me: loads an inferior R process 
when it launches without me asking it to or it asking me and it has 
the same bizarre behaviour when I run a shell.  One thing I've 
noticed is that if I run xemacs from an icon in c:\documents and 
settings\administrator\desktop\programs\ (my default place for things 
I run often) and if I then run esc-x shell I get two new empty 
subdirectories created off that directory, one named .exe, the other 
named -i.  I think there's clearly something wrong with my path, my 
registry or ... Here's path for what it's worth:
PATH=C:\Program Files\XEmacs\XEmacs-21.4.13\i586-pc-
:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program 
Files\Common Files\Roxio Shared\DLLShared;C:\Program Files\Common 
Files\GTK\2.0\bin;C:\progra~1\R\rw2001\bin;C:\Program Files\SPSS Data 
Access Pack\;c:\program files\gnuwin32\bin

I have also reinstalled emacs 21.3 and ESS 5.2.6 and they work 
together and, for now, I'm not reproducing my original bug (which had 
been consistent for weeks!) and sufficiently tired of this to 
consider shifting from xemacs to emacs though I had really got to 
like the icons and some differences in the menus that xemacs gives 
and the "run paragraph" option that I had in the earlier ESS I had 
there which seems to have gone from both ESS versions I have now.  

If any of you who would like to fix this do find the time to suggest 
things, please do.  After Saturday night GMT I'll be off on leave for 
a week so if I don't respond until the 11th it's not that I'm rude, 
it's just that I'm skiing almost as badly as I do elisp, but more 
happily I hope!!

Thanks all,

Chris Evans <chris at psyctc.org>
Consultant Psychiatrist in Psychotherapy, Rampton Hospital; 
Research Programmes Director, Nottinghamshire NHS Trust, 
Hon. SL Institute of Psychiatry
*** My views are my own and not representative of those institutions 

More information about the ESS-help mailing list