[ESS] Solved - no gnuclient in linux

Fredrik Lundgren fredrik.bg.lundgren at bredband.net
Tue Mar 29 23:15:36 CEST 2005


I found a way to make fix() and edit() work with gnuclient
in ESS-5.2.6/R-2.0.1/Xemacs-21.4.15-r3 on gentoo-linux.

When invoking R/ESS the following is induced by ESS
> options(STERM='iESS', editor='gnuclient -q')

It appears as if the problem is with 'gnuclient -q'
(whatever does -q signify??)
and when i changed a row in ess-5.2.6/lisp/gnu-cust.el
things worked in the expected way.
Change row

if (featurep 'xemacs) "gnuclient -q" "emacsclient"))) ;; unix


if (featurep 'xemacs) "gnuclient" "emacsclient"))) ;; unix

and all things work OK.

The only thing needed in init.el for gnuclient to work in this setup


and possibly

(setq gnuserv-frame (selected-frame))

if you whant the gnuclient frame to open within Xemacs

and no fuss with PATH

Many thanks to Richard M. Heiberger for all help!


PS A peculiar thing though - In the latest manual for ESS it's said:
4.9 Using emacsclient

When starting R or S under Unix, ESS sets options(editor="emacsclient"). 

Microsoft Windows, it will use gnuclient.exe rather than emacsclient, 
but the same principle


but I got options(editor="gnuclient -q")

now changed to options(editor="gnuclient ")


----- Original Message ----- 
From: "Richard M. Heiberger" <rmh at temple.edu>
To: "Fredrik Lundgren" <fredrik.bg.lundgren at bredband.net>
Cc: "ess-help-request at stat.math.ethz.ch" <ess-help at stat.math.ethz.ch>
Sent: Monday, March 28, 2005 5:07 PM
Subject: Re: [ESS] no gnuclient

>I am out of my range with linux.  An Xemacs-on-linux user
> will have to make further comments on the linux side.
> On windows, I think you do not yet have the right load-path specified.
> I have gnuserv in the following directory
> c:/emacs/gnuserv/
> and I have in it executables
> gnuclient.exe     ## use this one for edit, as it locks R and
>                  ## waits for the edit to complete.
> gnuclientw.exe    ## use this one for paging, as it doesn't lock R
> gnuserv.exe       ## background process
> My emacs exec-path includes
> "c:/emacs/gnuserv"
> My emacs load-path includes
> "c:/emacs/gnuserv"
> My site-start.el includes the lines
> (require 'gnuserv)  ## this loads c:/emacs/gnuserv/gnuserv.el into 
> emacs
> (gnuserv-start)     ## this executes c:/emacs/gnuserv/gnuserv.exe as
>                    ## a background process
> (setq gnuserv-frame (selected-frame)) ## this makes files stay in the 
> same frame
> Rich

More information about the ESS-help mailing list