[ESS] filename completion problem

Martin Maechler maechler at stat.math.ethz.ch
Thu Mar 24 17:59:20 CET 2005

>>>>> "Giovanni" == Giovanni d'Ario <giovanni.dario at ifom-ieo-campus.it>
>>>>>     on Thu, 24 Mar 2005 09:39:12 +0100 writes:

    Giovanni> One final (I promise!) observation: I've tried the
    Giovanni> ESS releases from 5.2.0 to 5.2.6 and I've observed
    Giovanni> that the problem occurs starting from 5.2.4. The
    Giovanni> previous releases don't show any problem.

Thank you very much, Giovanni; there's no need to make this the
last observation!

In the  mean time I have been able to partly reproduce your

Pressing [Tab] in an ``inferior-ess'' aka *R* buffer can produce
the error message   "Wrong type argument: stringp, nil" 
e.g., in the following situation

> source(" 
          ^ have the cursor here, after the (opening) double quote.

I haven't really seen the problem, since I use  M-Tab, not [Tab]
(alone) for file name completion; I use [Tab] (alone) for object
name completion only.

I now also remember that this topic has come up before, a few
months agao IIRC, but I don't recall all the conclusions from
back then.  We (ESS-core) did work on the completion
``business'', but did so mainly for the *object* completion (as
opposed to file name completion).

If other ESS-help readers have more observations / remarks /
wishes / ... on the topic of completion and [Tab] in
inferior-ess, please let them be heard now.

Otherwise, I propose the topic to be handled within ESS-core
(and a few interested ones, like Giovanni).


    Giovanni> Martin Maechler wrote:

    >> I try to summarize what I've learned till now:
    >> Giovanni did and said the following:
    >> - uses R 2.0.1 and Emacs 21.3.1 under Debian Sarge.
    >> - tried both the packaged version of ESS (ess-5.2.5-1
    >> "debian") and the tar.gz (5.2.6) manually configured as
    >> indicated in the README.
    >> - ``When I press tab to complete a filename the answer is
    >> "Wrong type argument: stringp, nil" ''
    >> - `` ESC TAB gives the same problem.  C-c TAB apparently
    >> has no effect. ''
    >> - `` if I press "Complete File Name" in the Complete
    >> menu, it works fine! ''
    >> - - - -
    >> But you didn't tell us *when* this happens: Are you
    >> inside a *R* buffer, or are you editing a *.R file (as
    >> you should be doing 95% of the time ;-)
    >> Also, I found myself that it's pretty hard *not* to use a
    >> debian-installed ESS version -- it's directory is added
    >> to the emacs load path ``long before'' a user ~/.emacs or
    >> any user "M-x ..." command comes into play.
    >> Did you uninstall the debian ess package before using the
    >> *.tar.gz one?  If you didn't, I'm pretty sure you were
    >> still using the debian one even though you explicitly
    >> loaded another ess-site.el file.
    >> Try M-x locate-library ess
    >> to find out from where emacs is getting the ESS parts.
    >> Regards, Martin

    Giovanni> ______________________________________________
    Giovanni> ESS-help at stat.math.ethz.ch mailing list
    Giovanni> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list