[ESS] system from emacs-ess

Angel Lopez angel_lul at hotmail.com
Sun Mar 6 21:31:05 CET 2005

Yes, I think you are right. When I call emacs from the bash console 
instead of clicking on my kde icon, the system call works fine.
I've tried to find how to setenv in R but I didn't manage. I've done 
help.search("setenv") and the best match seems to be Sys.putenv(base) 
but I can not find how to add a Path and run the file seadas.env.

A.J. Rossini wrote:q
> I can never remember if you should be using .bashrc or .profile for
> non-login shells, but it's probably a login shell vs. not issue as far
> as getting the path to be set.  You might consider using the R
> internal setenv commands to make sure it's in your path.
> best,
> -tony
> On Fri, 04 Mar 2005 15:56:58 +0100, Angel Lopez <angel_lul at hotmail.com> wrote:
>>Dear all,
>>I am trying to call seadas (a satellite data proccessing software) from
>>R using the "system" command.
>>I call seadas using system("seadas -em").
>>When I run R from the bash console it works fine but when I run R under
>>emacs-ess I get the message
>>system("seadas -em")
>>sh: seadas: command not found
>>To install seadas I had to modify my /etc/bash.bashrc file to add the
>>seadas directory to the path and to run a file seadas.env.
>>It seems like if that is not noticed under the shell emacs uses.
>>I've also tried
>>>system("bash seadas -em")
>>bash: seadas: No such file or director
>> I use Debian GNU/Linux.
>>ESS-help at stat.math.ethz.ch mailing list

More information about the ESS-help mailing list