[ESS] system from emacs-ess

A.J. Rossini blindglobe at gmail.com
Sat Mar 5 09:51:53 CET 2005

I can never remember if you should be using .bashrc or .profile for
non-login shells, but it's probably a login shell vs. not issue as far
as getting the path to be set.  You might consider using the R
internal setenv commands to make sure it's in your path.


On Fri, 04 Mar 2005 15:56:58 +0100, Angel Lopez <angel_lul at hotmail.com> wrote:
> Dear all,
> I am trying to call seadas (a satellite data proccessing software) from
> R using the "system" command.
> I call seadas using system("seadas -em").
> When I run R from the bash console it works fine but when I run R under
> emacs-ess I get the message
> system("seadas -em")
> sh: seadas: command not found
> To install seadas I had to modify my /etc/bash.bashrc file to add the
> seadas directory to the path and to run a file seadas.env.
> It seems like if that is not noticed under the shell emacs uses.
> I've also tried
> > system("bash seadas -em")
> bash: seadas: No such file or director
>  I use Debian GNU/Linux.
> Thanks,
> Angel
> ______________________________________________
> ESS-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help


"Commit early,commit often, and commit in a repository from which we can easily
roll-back your mistakes" (AJR, 4Jan05).

A.J. Rossini
blindglobe at gmail.com

More information about the ESS-help mailing list