[ESS] - SOLVED - ess causes xemacs crash in Fedora Core 4

Marc Schwartz MSchwartz at mn.rr.com
Wed Jun 15 16:23:15 CEST 2005

On Wed, 2005-06-15 at 10:08 -0400, Jonathan Baron wrote:
> Problem solved with updating.
> Sorry to bother everyone.  I just hadn't realized how many
> updates there have been since the "release" of FC4, which
> actually came out a week late.  For one thing, the installer did
> not update xemacs from the FC3 version.  And there is a new
> version of xorg-xll.
> So, the message is: AFTER YOU INSTALL FC4, RUN "YUM UPDATE"
> On 06/15/05 08:37, Marc Schwartz wrote:
>  On Wed, 2005-06-15 at 08:20 -0400, Jonathan Baron wrote:
>  > I just upgraded to Fedora Core 4.  Now xemacs crashes when I try
>  > to load a file into it, or when I start with "xemacs -f R."  If I
>  > remove all references to ess from the init.el file, xemacs works
>  > as usual except for using ess, of course.  Upgrading ess to 5.2.8
>  > did not help.  What does help is using xemacs -nw.  That is the
>  > apparent workaround for now, but of course it loses a lot.
>  >
>  > Anyone else have this problem?  I have not yet tried fooling
>  > around with .Xresources or with ess itself.
>  >
>  > Jon
>  Jon,
>  When you open xemacs, does it come up in a maximized window?
> Not really.  It is pseudo-maximized through settings in
> .Xresources, which make it as big as possible within the
> constraints of the fonts.
>  If so, there is a known bug/interaction between xemacs and metacity
>  (GNOME's default window manager) which causes xemacs to exhibit behavior
>  ranging from a lock up situation, to a crash, to flickering. This
>  problem has been around for a few versions of RH/FC
> Don't get that.

Interesting. If I read correctly, it looks like you updated, whereas I
did a clean install of FC4. I wonder how that interaction might affect

>  One other thing that I have noted, which is when doing a "find" in
>  xemacs using the dialog from the menu, text entered does not appear in
>  the dialog field, but below the dialog. In order to see this, you need
>  to drag the lower window border larger to reveal the lower section of
>  the dialog. This is new for FC4.
> I don't see this problem either.  I didn't even know that Find
> existed.  But it works.  I use ctrl-s.

Curious. On my clean install, which is fully updated as of this morning,
I still get both behaviors.

I have posted to the fedora-extras list on these. We'll see if anyone
else is having the problem.

Best regards,


More information about the ESS-help mailing list