R: [ESS] on "Check inferior-ess-prompt or ess-loop-timeout"

8rino-Luca Pantani ottorino-luca.pantani at unifi.it
Fri Dec 17 11:08:04 CET 2004

>Dear Ottorino-Luca,
>I believe that you're experiencing an incompatibility between your version
>of my init file and the version of ESS that you're using. Have you tried a
>newer version of my init file? The current one on my web site
>(http://socserv.socsci.mcmaster.ca/jfox/Books/Companion/ESS/index.html) is
>Version 0.6.1, dated 5 November 2004.

Yesterday evening I tried the new version, but regrettably without success.

1st attempt
after changing those lines that reflect the local situation (i.e. the path
to R and ESS)
I've been running the new init.el file, and still get the same error in the
"Check inferior-ess-..........

2nd attempt
I started xemacs with the -q option and evaluate the init.el
with "evaluate the whole buffer" and get a large init.el window (in which R
is loaded)
on top of the scratch window (the grey tag of scratch is visible)

When I click on that grey tag, I get the message
"Cannot switch buffers in a dedicated window".
This morning I'm trying to repeat this procedure, and always get the same
except once in which I get the lower R window and the scratch above, but
there is
the usual message, this time in the echo area, instead that in the warnings.
I think it was an accident, because I see it only once.

3rd attempt
If I evaluate the init.el line by line, everything goes fine
except for the last line,
after which I find myself in the same situation of the 2nd attempt


More information about the ESS-help mailing list