[BioC] flowQ loading error after installing ImageMagick

Chandra Jack chanj at rice.edu
Tue Mar 5 05:07:23 CET 2013

The convert command isn't in my PATH but adding the newIt doesn't seem to be working. I don't have a .bashrc file but I have a .bash_profile. The original file was:
# Setting PATH for EPD-7.1-2
# The orginal version is saved in .bash_profile.pysave
export PATH


# Setting PATH for Python 2.7
# The orginal version is saved in .bash_profile.pysave
export PATH

# Your previous /Users/chanj/.bash_profile file was backed up as /Users/chanj/.bash_profile.macports-saved_2013-03-04_at_14:30:35

# MacPorts Installer addition on 2013-03-04_at_14:30:35: adding an appropriate PATH variable for use with MacPorts.
export PATH=/opt/local/bin:/opt/local/sbin:$PATH
# Finished adapting your PATH environment variable for use with MacPorts.

I added PATH=$PATH:/opt/local/bin after the export line, resaved the text edit file and quit the terminal. When I checked Terminal again the file was updated but R couldn't find the command still.

I also tried adding it before the export line, replacing the part after the export line with it, adding quotation marks but nothing seemed to work.  I went in and found the convert command file and it is in opt/local/bin. I tried Sys.which with another file that was in the same location and R output "/usr/bin/clear" .  Could it be related to the backup file that was created before I changed it?


On Mar 4, 2013, at 4:15 PM, Dan Tenenbaum wrote:

> On Mon, Mar 4, 2013 at 2:09 PM, Chandra Jack [guest]
> <guest at bioconductor.org> wrote:
>> Hi All,
>> I'm having a problem that has been mentioned here before but I'm not sure how to fix it. I tried to load flowQ and got:
>> Error : .onAttach failed in attachNamespace() for 'flowQ', details:
>>  call: mysys("convert -list configure", intern = TRUE, ignore.stderr = TRUE)
>>  error: error in running command
> Is the 'convert' command in your PATH?
> What is the output of the R command:
> Sys.which("convert")
> ?
> If it does not output anything, then the convert command is not in your PATH.
> I'm not sure where the convert command ended up, but I'm guessing it's
> in /opt/local/bin,
> so I think you need to edit your ~/.bashrc
> file and add the following line:
> PATH=$PATH:/opt/local/bin
> Then, start a new terminal window to make sure this setting is
> enabled, and try again.
> Dan
>> In addition: Warning messages:
>> 1: replacing previous import ‘plot’ when loading ‘graphics’
>> 2: replacing previous import ‘as’ when loading ‘methods’
>> Error: package/namespace load failed for ‘flowQ’.
>> I have installed ImageMagick using Macports as has been suggested and I have also run
>> convert -list configure, which gave the following:
>> Path: /opt/local/lib/ImageMagick-6.8.0/config/configure.xml
>> Name          Value
>> -------------------------------------------------------------------------------
>> CC            /usr/bin/gcc-4.2 -std=gnu99 -std=gnu99
>> CFLAGS        -D_THREAD_SAFE -D_THREAD_SAFE -pthread -fopenmp -pipe -O2 -arch x86_64 -Wall -D_THREAD_SAFE -pthread
>> CODER_PATH    /opt/local/lib/ImageMagick-6.8.0/modules-Q16/coders
>> CONFIGURE     ./configure  '--prefix=/opt/local' '--enable-shared' '--enable-static' '--disable-ltdl-install' '--disable-silent-rules' '--with-frozenpaths' '--without-openexr' '--disable-hdri' '--with-dps' '--with-bzlib' '--with-fontconfig' '--with-gslib' '--with-jpeg' '--with-lcms' '--with-png' '--with-tiff' '--with-webp' '--with-zlib' '--with-modules' '--with-xml' '--with-x' '--without-perl' '--without-fpx' '--without-jbig' '--without-jp2' '--without-wmf' '--without-gvc' '--without-rsvg' '--without-lqr' '--without-pango' '--with-gs-font-dir=/opt/local/share/fonts/urw-fonts' '--with-quantum-depth=16' 'CC=/usr/bin/gcc-4.2' 'CFLAGS=-pipe -O2 -arch x86_64' 'LDFLAGS=-L/opt/local/lib -arch x86_64' 'CPPFLAGS=-I/opt/local/include' 'CXX=/usr/bin/g++-4.2' 'CXXFLAGS=-pipe -O2 -arch x86_64'
>> CONFIGURE_PATH /opt/local/etc/ImageMagick/
>> COPYRIGHT     Copyright (C) 1999-2012 ImageMagick Studio LLC
>> CPPFLAGS      -I/opt/local/include/ImageMagick
>> CXX           /usr/bin/g++-4.2
>> CXXFLAGS      -pipe -O2 -arch x86_64 -D_THREAD_SAFE -pthread
>> DEFS          -DHAVE_CONFIG_H
>> DELEGATES     bzlib fftw fontconfig freetype gs jpeg jng lcms2 lzma png tiff x11 xml zlib
>> DISTCHECK_CONFIG_FLAGS 'CC=/usr/bin/gcc-4.2' 'CFLAGS=-pipe -O2 -arch x86_64' 'CPPFLAGS=-I/opt/local/include' 'CXX=/usr/bin/g++-4.2' 'LDFLAGS=-L/opt/local/lib -arch x86_64' --disable-deprecated --with-quantum-depth=16 --with-umem=no --with-autotrace=no --with-fpx=no --with-fontpath= --with-gs-font-dir=/opt/local/share/fonts/urw-fonts --with-gvc=no --with-jp2=no --with-lqr=no --with-openexr=no --with-pango=no --with-rsvg=no --with-wmf=no --with-perl=no
>> DOCUMENTATION_PATH /opt/local/share/doc/ImageMagick-6.8.0
>> EXEC-PREFIX   /opt/local
>> EXECUTABLE_PATH /opt/local/bin
>> FEATURES      OpenCL OpenMP
>> FILTER_PATH   /opt/local/lib/ImageMagick-6.8.0/modules-Q16/filters
>> HOST          x86_64-apple-darwin10.8.0
>> INCLUDE_PATH  /opt/local/include/ImageMagick
>> LDFLAGS       -L/opt/local/lib -L/opt/local/lib -arch x86_64 -L/opt/local/lib -L/opt/local/lib
>> LIB_VERSION   0x680
>> LIBRARY_PATH  /opt/local/lib/ImageMagick-6.8.0
>> LIBS          -lMagickCore -llcms2 -lfreetype -lfftw3 -L/opt/local/lib -lfontconfig -lXext -lSM -lICE -lX11 -lXt -L/opt/local/lib -llzma -lbz2 -lz -lltdl -lm -lgomp -lclparser -Wl,-framework,OpenCL -L/System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries -lm -lpthread
>> NAME          ImageMagick
>> PCFLAGS       -fopenmp
>> PREFIX        /opt/local
>> QuantumDepth  16
>> RELEASE_DATE  2013-03-04
>> SHARE_PATH    /opt/local/share/ImageMagick-6.8.0
>> SVN_REVISION  10029
>> TARGET_CPU    x86_64
>> TARGET_OS     darwin10.8.0
>> VERSION       6.8.0
>> WEBSITE       http://www.imagemagick.org
>> Path: [built-in]
>> Name          Value
>> -------------------------------------------------------------------------------
>> NAME          ImageMagick
>> Any help would be appreciated. Thanks
>> -- output of sessionInfo():
>> R version 2.15.2 (2012-10-26)
>> Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit)
>> locale:
>> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
>> attached base packages:
>> [1] tools     stats     graphics  grDevices utils     datasets  methods   base
>> other attached packages:
>> [1] latticeExtra_0.6-24   RColorBrewer_1.0-5    parody_1.16.0         bioDist_1.30.0
>> [5] KernSmooth_2.23-8     mvoutlier_1.9.9       sgeostat_1.0-25       robCompositions_1.6.3
>> [9] car_2.0-16            nnet_7.3-5            compositions_1.20-1   energy_1.4-0
>> [13] MASS_7.3-23           boot_1.3-7            tensorA_0.36          rgl_0.93.928
>> [17] flowViz_1.22.0        flowCore_1.24.2       rrcov_1.3-02          pcaPP_1.9-48
>> [21] mvtnorm_0.9-9994      robustbase_0.9-5      Biobase_2.18.0        lattice_0.20-13
>> [25] outliers_0.14         BiocGenerics_0.4.0    BiocInstaller_1.8.3
>> loaded via a namespace (and not attached):
>> [1] annotate_1.36.0      AnnotationDbi_1.20.5 DBI_0.2-5            feature_1.2.8
>> [5] flowQ_1.18.0         geneplotter_1.36.0   graph_1.36.2         grid_2.15.2
>> [9] hexbin_1.26.1        IDPmisc_1.1.17       IRanges_1.16.6       ks_1.8.11
>> [13] parallel_2.15.2      RSQLite_0.11.2       stats4_2.15.2        XML_3.95-0.1
>> [17] xtable_1.7-1
>> --
>> Sent via the guest posting facility at bioconductor.org.
>> _______________________________________________
>> Bioconductor mailing list
>> Bioconductor at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/bioconductor
>> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

Chandra Jack
Postdoctoral Research Assoc.
Dept. of Bioengineering
Rice University
chanj at rice.edu

More information about the Bioconductor mailing list