[BioC] Problems using arrayQualityMetrics

Wolfgang Huber whuber at embl.de
Fri Mar 23 00:39:51 CET 2012

Dear Rosalind

unfortunately, the fact that the package manager on your Redhat Linux 
does not provide you with a newer version does not mean that there is 
none. The Linux distribution that you are using seems to be very much 
behind in time: cairo 1.2.4 is from 2006, see http://cairographics.org/

Two options:
- use a system that is better kept up-to-date
- remove the cairo that your package manager gives you, and install 
libcairo >=1.10.2 'manually' by downloading it from the above URL.

Btw, I would also also prefer if arrayQualityMetrics (i.e., really the 
SVGAnnotation package) was backwards compatible with any old version of 
cairo, but that is not a realistic expectation (neither for our 
software, nor for many other products, incl. commercial).

	Best wishes

Mar/22/12 12:38 PM, Rosalind Cutts scripsit::
> Thanks very much for the reply, I have tried this with a clean R and bioconductor installation and get a similar error.
> ArrayQualityMetrics works ok, it just fails to produce some of the graphical output.
>   Cairo version:
> pkg-config --modversion cairo
> 1.2.4
> When I tried updating Cairo on the Redhat linux machine I am using as suggested by your link there were no updates to load.
> Is there anything else that you could suggest I could try.
> Thanks again for your help
> Ros

Wolfgang Huber

More information about the Bioconductor mailing list