[BioC] Problems loading the "flowStats" package

Stephan Fuhrmann stephan.fuhrmann at charite.de
Tue Sep 20 21:20:30 CEST 2011

dear all,

 i encountered a problem when trying to use the flowStats package.
i found the same error described, but there was no solution:

On Mon, Sep 5, 2011 at 6:03 PM, Juliet Frederiksen
<juliet.frederiksen at ...> wrote:
> Hi everyone,
> I am a masters student working with flow cytometry data analysis, and while
> working on my data I came across the "flowStats" package, but I am
unable to
> load it in R.
> Error : object 'data2fd' is not exported by 'namespace:fda'
> Error: package/namespace load failed for 'flowStats'
> When I looked into it some more, when looking into the fda package,
there is
> a function called 'Data2fd'.
> When having a look at the NAMESPACE file of "flowStats":
> importFrom(fda, create.bspline.basis, data2fd, eval.fd, fdPar,
>           landmarkreg)
> So I tired to change the "flowStats" NAMESPACE file to:
> importFrom(fda, create.bspline.basis, Data2fd, eval.fd, fdPar,
>           landmarkreg)
> but this did not help...
> Any suggestions as to what I should do?
i downloaded the flowStats_1.10.0 mac binary from bioconductor.org. i
checked the versions of the dependencies, which seem to be okay.

 Any suggestion how i can fix this problem.

 i attach you the console and sessionInfo:

 thanks a lot,


R version 2.13.1 (2011-07-08)
Platform: i386-apple-darwin9.8.0/i386 (32-bit)

[1] de_DE.UTF-8/de_DE.UTF-8/C/C/de_DE.UTF-8/de_DE.UTF-8

attached base packages:
[1] splines   grid      stats     graphics  grDevices utils     datasets 
methods   base

other attached packages:
 [1] cluster_1.14.0        mvoutlier_1.9.3       robCompositions_1.5.0
 [5] survival_2.36-9       nnet_7.3-1            compositions_1.10-1  
 [9] MASS_7.3-14           boot_1.3-2            tensorA_0.36         
[13] fda_2.2.7             zoo_1.7-4             flowCore_1.18.0      
[17] pcaPP_1.9-44          mvtnorm_0.9-9991      robustbase_0.7-6     
[21] flowType_0.99.4       Rgraphviz_1.30.1      graph_1.30.0

loaded via a namespace (and not attached):
 [1] feature_1.2.8     flowClust_2.10.0  flowMeans_1.4.0   flowMerge_2.0.3
 [6] ks_1.8.2          lattice_0.19-33   sfsmisc_1.0-14    stats4_2.13.1  
> library(flowStats)
Error : Objekt ‘data2fd’ ist nicht von 'namespace:fda' exportiert
Fehler: Laden von Paket/Namensraum für 'flowStats' fehlgeschlagen
> traceback()
2: stop(gettextf("package/namespace load failed for '%s'", package),
       call. = FALSE, domain = NA)
1: library(flowStats)

More information about the Bioconductor mailing list