[BioC] Curious error with 'subseq' function from BSgenome (IRanges)

J.delasHeras at ed.ac.uk J.delasHeras at ed.ac.uk
Mon Jun 7 15:46:24 CEST 2010

Quoting Martin Morgan <mtmorgan at fhcrc.org>:

> On 06/04/2010 03:52 AM, J.delasHeras at ed.ac.uk wrote:
>> Hi everyone,
>> I am using the BSgenome package and annotations to retrieve several
>> thousand sequences (22k) corresponding to a promoter microarray.
>> Basically I run a loop through the whole list of chromosome name, start,
>> and stop coordinates, and retrieve each 1Kb sequence using the 'subseq'
>> function.
>> When I run it, I get the following error *sometimes*:
>> Error in get(name, envir = .classTable) :
>>   formal argument "envir" matched by multiple actual arguments
> Hi Jose --
> This sounds like a bug in R, fixed in the R-2.11.* series, and updating
> your R (and packages, see http://bioconductor.org/docs/install/) should
> fix this. If not, it would be great to hear...
> Martin

Just a quick update:

I ran the same code with the latest R/BioC a couple of times and  
didn't encounter a single error, so it does seem that it's ok now.

Thank you.


The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

More information about the Bioconductor mailing list