[BioC] Error coerce in AffyQCReport

Lorenzo Melchor lorenzo.melchor at icr.ac.uk
Wed Dec 1 12:23:11 CET 2010

Hi, Sean.

Please, find attached one or the examples that I have tried to run.  
The problem is regardless of the samples you work with.


On 1 Dec 2010, at 11:17, Sean Davis wrote:

> On Wed, Dec 1, 2010 at 5:59 AM, Lorenzo Melchor <lorenzo.melchor at icr.ac.uk 
> > wrote:
> Hi there,
> I have been trying to use AffyQCReport for a few days now and I keep
> having the same problem again and again.
> I load the package with the usual library(affy) and
> library(affyQCReport) commands, so I type then the next command
> obtaining an error as a result.
>  > QCReport(test,file="qualityReport.pdf")
> Error in as.double(y) :
>   cannot coerce type 'S4' to vector of type 'double'
> When checking in my working directory, I find a pdf file with only the
> first two pages of any AffyQCReport.
> It seems odd because some other people at my centre has tried to do
> the same analysis, and got the same error.
> Would you know which the cause would be?
> Hi, Lorenzo.
> Can you give a reproducible example and sessionInfo()?
> Sean

Lorenzo Melchor, PhD
Mammary Stem Cell Team
The Breakthrough Breast Cancer Research Centre (ICR)
237 Fulham Road
lorenzo.melchor at icr.ac.uk

The Institute of Cancer Research: Royal Cancer Hospital, a charitable Company Limited by Guarantee, Registered in England under Company No. 534147 with its Registered Office at 123 Old Brompton Road, London SW7 3RP.

This e-mail message is confidential and for use by the addressee only.  If the message is received by anyone other than the addressee, please return the message to the sender by replying to it and then delete the message from your computer and network.

More information about the Bioconductor mailing list