[BioC] problems with marray and gpr files

Jörg edd17 at gmx.de
Sun Jan 18 13:05:47 CET 2009

I am pretty new to marray and actually having the same problem.
When using read.GenePix() I get the error

""Error in if (skip > 0) readLines(file, skip) :
 >         missing value where TRUE/FALSE needed"

Additionally I get a warning message

": In grep(layout.id[1], y) :
Inputstring  30 not valid with this locale."

When using the skip option with the number of row in the header I get

"Error in `[.data.frame`(dat, , info.id) : undefined columns selected"

I tried different gpr files also files downloaded from:


The columns are named exactly as expected in read.GenePix()
so I don't think it is a problem with the files.

Here they mention that it might be a problem with R locate:

Unfortunately I don't know a lot about this.

My System:

Ubuntu Feisty Fawn, Linux 2.6.24-23-generic i686,
R version 2.8.1 (also tried older versions), Bioconductor 2.3

I would be very grateful for every help or hint.

thanks a lot,

More information about the Bioconductor mailing list