[BioC] ReadAffy fails 64bit linux Error in .nextMethod(e1, e2) :

Martin Morgan mtmorgan at fhcrc.org
Tue Apr 1 15:11:50 CEST 2008

Thanks for following through, Bill.

The 'release' version of BioConductor packages have an even digit as the 
second part (the 'y' in x.y.z) of their version number, so if you're 
using a current R you probably meant 1.6.1.

For what it's worth, this is one reason why sessionInfo() can be so 
useful -- does the version of the package match the version of R and 
BioConductor? Assuming you're using the current released version of R, 
an easy way to check for yourself is to compare package versions 
reported by sessionInfo() with the version numbers on the pages linked 
from the 'Packages' link of http://bioconductor.org. And then to update 
packages, if necessary, using instructions on 

Thanks again,


Langdon W B wrote:
> Dear Sean, James and Martin,
>                             Thank you for your advice.
> My collegue resolved the problem after noting an earlier error when
> affyio 1.4.1 was orginally installed (rather than the required 1.5.1)
> and has just reinstalled it and all of the other biocLite packages.
> 			 Thanks again
>                                 Bill
>         W. B. Langdon,
>         Mathematical Sciences,
>         University of Essex
>         Wivenhoe Park,
>         Colchester CO4 3SQ, UK
>         http://www.essex.ac.uk/maths/staff/langdon/
> A Field Guide to Genetic Programming
>                        http://www.gp-field-guide.org.uk/
> CIGPU 2008	       http://www.cs.ucl.ac.uk/staff/W.Langdon/cigpu/
> GP EM                  http://www.springer.com/10710
> GP Bibliography        http://www.cs.bham.ac.uk/~wbl/biblio/

More information about the Bioconductor mailing list