[BioC] outdated version of 'affy' in biocLite ?
hpages at fhcrc.org
hpages at fhcrc.org
Tue Jan 16 01:53:02 CET 2007
Quoting "Talloen, Willem [PRDBE]" <WTALLOEN at PRDBE.JNJ.COM>:
> dear all,
> The package installation for the R version 2.4 on our Linux server stopped -
> apparently because of an outdated version of affy (see error message below).
The version of affy you have (probably 1.12.*) is the expected
version for BioC-1.9/R-2.4 users but you seem to have the devel
version of affydata (1.11.1) which itself requires the devel version
You didn't do anything wrong: biocLite() is catching the wrong version
of affydata for BioC-1.9/R-2.4 users. I've just fixed the problem (last
week I inadvertendly dropped affydata devel in the 1.9/data/experiment
Please re-install affydata with biocLite(): you should now catch
the correct version (1.10.0).
Thanks for reporting this and sorry for the inconvenience.
> A more general question - has anybody an helpful suggestion how to maintain
> R and its BioC packages on a server? Our informaticians are getting annoyed
> with our frequent questions about adding or updating packages, and also with
> the dependencies between versions of the different packages. I thought to
> apply BiocLite more routinely now that we are switching to 2.4, but this
> -again- doesn't work out as smoothly as we hoped it to be.
If R is installed at the system level, I can suggest this (not really tested):
1. Install and update a group of system-wide shared packages (as root):
- run biocLite() (with no argument) or biocLite(groupName='all')
only once (after a fresh install of R)
on a regular basis (e.g. 1/week).
2. Each user can administrate its own group of extra packages:
- define your personal R library folder with (from the shell):
- use biocLite() to install packages that are not found system-wide
(by default, biocLite will install them in your ~/Rlibs)
- update packages in your ~/Rlibs on a regular basis:
Note that using lib.loc=.libPaths() prevents you from
trying to update the system-wide shared packages.
Hope this helps...
> thanks in advance,
> error message;
> Loading required package: affy
> Loading required package: Biobase
> Loading required package: tools
> Loading required package: affyio
> Loading required package: affydata
> Error: package 'affy' 1.12.2 is loaded, but >= 1.13.9 is required by
> Execution halted
> cat: write error: Broken pipe
> ERROR: execution of package source for 'affyPLM' failed
> ** Removing
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> Search the archives:
More information about the Bioconductor