[BioC] mapGeneInfo (from marray) could not find function "widgetRender"

Jean Yee Hwa Yang jeany at maths.usyd.edu.au
Thu Apr 5 13:56:19 CEST 2007

Hi Jay,

There are two ways of using the mapGeneInfo function: command line and 
I will discuss with John off-list what is the best way to get the widget 
component working for mapGeneInfo.  But for the moment, if you like to 
creat the mapping, you can write a simple one line command:

For example, in your mraw at Gnames@maInfo, if you have the following 

"ProbeID", "ProbeName"

where "ProbeID" have accession number.  Than you can running 
the following line to enable a html link to the Source web site later on 
when using the function htmlPage.


Please e-mail me if you like more help setting the mapping up.



On Thu, 5 Apr 2007, Seth Falcon wrote:

> Hi Jay,
> Jay Konieczka <jayk at u.arizona.edu> writes:
>> Hi,
>> I couldn't find anything in the archives so I apologize if it was
>> there and I missed it.  When I try to run mapGeneInfo with the widget
>> I get the following error:
>> > map = mapGeneInfo(widget=TRUE, mraw at maGnames)
>> [1] "widget"
>> Error in widget.mapGeneInfo(Gnames) : could not find function
>> "widgetRender"
>> I'm running R 2.4.1 on a Mac OS X (10.4.9).  I have the latest
>> version of Bioconductor and tkWidgets version 1.12.1
> THe widgetRender function is defined in tkWidgets but not currently
> exported in the NAMESPACE.  Nothing has changed there recently, so
> this may have been a problem for awhile.
> The widget functionality has other issues even once the
> widgetRender function is found.  I've cc'd the maintainers of both
> tkWidgets and marray in hopes they can take a look and provide
> additional information.
> Best,
> + seth
> -- 
> Seth Falcon | Computational Biology | Fred Hutchinson Cancer Research Center
> http://bioconductor.org

More information about the Bioconductor mailing list