[BioC] problem with limma and BlueFuse

Gordon K Smyth smyth at wehi.EDU.AU
Thu Jun 22 13:45:49 CEST 2006

> Date: Tue, 20 Jun 2006 17:51:54 +0000
> From: "Alessio Venier" <0509388V at student.gla.ac.uk>
> Subject: [BioC] problem with limma and BlueFuse
> To: bioconductor at stat.math.ethz.ch
> Hi,
> I've a problem using limma with bluefuse output files (I've saved those files as .xls)
> I'm able to use one file per time without any trouble but when I try to load more than
> one file using a "target" file, I receive an error message.
> I've installed R 2.3.1 and limma 2.7.3
> Sample session below:
> #Using right package!
> #I create an object as a target from file
>> target<-readTargets(file="targets.txt",path="C:\\Playground\\Micro")
> #This is the object
>> target
>        SlideNumber Name   FileName     Cy3       Cy5
> array1           1   c1 array1.xls control treatment
> array2           2   c2 array2.xls control treatment
> #and how I use the read.maimage
>> RG<-read.maimages(target$FileName,source="bluefuse",path="C:\\Playground\\Micro")
> Read C:\Playground\Micro/array1.xls
> Error in switch(source2, quantarray = { : could not find function "readBlueFuseHeader"
> #I've also tried to use a vector with file names instead of a target object,
> #but the result happen to be the same.
>> files<-c("array1.xls","array2.xls")
>> RG<-read.maimages(files,source="bluefuse",path="C:\\Playground\\Micro")
> Read C:\Playground\Micro/array1.xls
> Error in switch(source2, quantarray = { : could not find function "readBlueFuseHeader"
> #I've not found any information about readBlueFuseHeader in the documentation (i'm using ver.
> 2.7.3)
> #If I call the function I receive the same error!
>> readBlueFuseHeader()
> Error: could not find function "readBlueFuseHeader"
> I'm a new user of R, please let me know what I'm doing wrong.
> Kind Regards
> Alessio

Dear Alessio,

This is a bug which I unfortunately introduced into limma 2.4.11.  I removed the function
readBlueFuseHeader() but forgot to remove all references to it.

Thanks to Mike Smith at the University of Cambridge who emailed me about the problem yesterday,
the bug has already been fixed in limma 2.7.5 which I submitted to CRAN about 12 hours ago.  You
should be able to get the bux fix from CRAN very soon by typing


at the R prompt.

Best wishes

PS. This bug has a lot to do with the fact that I don't have examples of recent BlueFuse data
files to test the code out on.  If someone could send me a couple of example data files, it would
be much appreciated.

More information about the Bioconductor mailing list