[BioC] Ruuid had non-zero exit status

Herve Pages hpages at fhcrc.org
Fri Jun 16 01:01:41 CEST 2006


Just to know wether this is an R/BioC/Ruuid or a Sparc/glib/gcc related pb,
can you please try this:

    gcc -I/package/R/2.3.1/lib/R/include -I/package/R/2.3.1/lib/R/include \
    -I/usr/local/include -I/ usr/local/include/glib-2.0 \
    -I/usr/local/lib/glib-2.0/include -DHAVE_UNISTD_H=1 -fPIC -O2 \
    -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE=1 -c Rinit.c -o Rinit.o

with the Rinit.c file replaced by the following test.c file:

    #include <glib.h>
    int main() {}

If you do _not_ get this anymore

    /usr/local/include/glib-2.0/glib/gtypes.h:41: error: syntax error
    before "typedef"

then we will know for sure that it's a Ruuid pb.

If you still get the error, then we'll have to look somewhere else. Then 
you could try:

    gcc -I/usr/local/include -I/ usr/local/include/glib-2.0
    -I/usr/local/lib/glib-2.0/include test.c

and if you still get an error then we will no for sure that this is a 
Sparc/glib/gcc related pb.



zph at herald.ox.ac.uk wrote:
> On Tue, 13 Jun 2006, Herve Pages wrote:
> ...
> Hi, Herve: 
> These are for handling large files in R. They work 
> well with R pre-2.3
> Looks likely that changes in Ruuid 1.8.0 cause 
> the problem. I find Ruuid 1.5.3 can be installed 
> it doesn't work because R complains its namespace
> is missing.
> I hope the BioC developers would consider to
> maintain the packages like Perl modules under
> CPAN. In other words, previous installed CRAN
> packages should be usable for later version
> of R/BioC unless users want to update them.
> Regards,
> Zong-Pei

Hervé Pagès
E-mail: hpages at fhcrc.org
 Phone: (206) 667-5791
   Fax: (206) 667-1319

More information about the Bioconductor mailing list