[Bioc-devel] BiocCheck warnings and errors

Christian Arnold chr@rno|d @end|ng |rom web@de
Tue Sep 13 17:03:00 CEST 2022

I have a few questions regarding BiocCheck errors and warnings that I
receive for a new package version that I feel are not warranted:

1. I want to use the testthat framework in combination with
devtools::test, and from my understanding, a subdirectory /testthat/
within tests has to be used for this and is created when using
devtools::test(). I still get an ERROR when using BiocCheck because I
have no .R files in tests/ but within tests/testthat:

* Checking unit tests... * ERROR: Add a .R or .Rin file in tests/
directory or unit tests will not be run by R CMD check. See

2. My package has many packages listed in Suggests, with a lot of effort
I tried to move as many packages there as possible to reduce the
installation burden. From my understanding, BiocManager does NOT install
the packages listed under /Suggests/. Thus, since I have 10+ packages in
/Suggests/ that actually enhance user functionality and may be needed, I
wrote a helper function that automatically installs these if the user
wants, as a convenience so users dont have to install them manually on
their own. However, no I get this error:

ERROR: Remove install() calls (found 2 times)

3. Minor but still: Can I use Biochceck also for the devel branch? I get
the following warning because I am checking the devel version and not
the release version:

WARNING: y of x.y.z version should be even in release

***Thanks for your input and thoughts!****Christian*

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list