[Bioc-devel] Cannot get ggplot2 3.4.0 from github actions

Stevie Pederson @tephen@peder@on@@u @end|ng |rom gm@||@com
Tue Nov 8 17:09:48 CET 2022

The release of ggplot2 3.4.0 has broken the ngsReports nightly build in
RELEASE_3_16. I've been through the package and corrected everything to
resolve the errors, but cannot get github actions to install ggplot2 3.4.0.
Personally, I like to pass a github actions test before pushing to the
current release branch.

I've tried adding '/nocache' in the commit message and I've tried updating
the cache using `cache-version: 'cache-v2'` in my workflow. The problem
seems to be in my matrix config, where I've set the package manager to be
`rspm: "packagemanager.rstudio.com/cran/__linux__/focal/latest" ` which
seems to use the out of date  "
https://packagemanager.rstudio.com/cran/__linux__/focal/2022-10-28" and
which only has ggplot2 3.3.36 . However, when I manually check
https://packagemanager.rstudio.com/cran/latest/src/contrib/PACKAGES I can
see that ggplot2 3.4.0 is available in the latest release.

I've also set the container to be
"bioconductor/bioconductor_docker:RELEASE_3_16" in my matrix config. Is
there some weird conflict between the Bioc docker & rstudio packagemanager?
Or do I just need to sit it out for a few days & hope it resolves?

Thanks & I'm a bit out of my depth with github actions so hopefully I've
spotted the right things.

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list