[Bioc-devel] Unable to install bioconductor package in bioconductor docker

David Jimenez-Morales b|od@v|djm @end|ng |rom gm@||@com
Sun Jan 17 20:32:44 CET 2021

Dear bio

I am trying to install the bioconductor package "mzR" in the following
bioconductor docker containers without success:

(and also tried, tidyverse:3.6.1)

Nitash Turaga was able to install it successfully on the devel docker (
bioconductor/bioconductor_docker:devel), however I tried without success,
which doesn't make any sense at all.

These are the commands that I tried:

--> docker --version
Docker version 20.10.2, build 2291f61

--> docker pull bioconductor/bioconductor_docker:devel
devel: Pulling from bioconductor/bioconductor_docker
Status: Image is up to date for bioconductor/bioconductor_docker:devel

docker run -it --rm bioconductor/bioconductor_docker:devel /bin/bash

root using 5d6bbd03317a:/# R

R Under development (unstable) (2021-01-14 r79832) -- "Unsuffered
Copyright (C) 2021 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

Bioconductor version 3.13 (BiocManager 1.30.10), ?BiocManager::install for

> BiocManager::install("mzR")
Bioconductor version 3.13 (BiocManager 1.30.10), R Under development
  (2021-01-14 r79832)
Installing package(s) 'mzR'

... (after compilation)

/usr/include/c++/9/bits/unique_ptr.h:53:28: note: declared here
   53 |   template<typename> class auto_ptr;
      |                            ^~~~~~~~
g++: fatal error: Killed signal terminated program cc1plus
compilation terminated.
make: *** [/usr/local/lib/R/etc/Makeconf:177: pwiz/data/common/Unimod.o]
Error 1
ERROR: compilation failed for package ‘mzR’
* removing ‘/usr/local/lib/R/site-library/mzR’

The downloaded source packages are in
Warning message:
In install.packages(...) :
  installation of package ‘mzR’ had non-zero exit status


- Any idea why it cannot be installed in the release Bioconductor dockers?
- how is possible that Nitesh can install it and I cannot in the exact same
bioconductor dev version?

Thanks a lot

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list