[Bioc-devel] Question reg devtools in MacOS High Sierra

Martin Morgan mtmorg@n@b|oc @end|ng |rom gm@||@com
Fri Feb 12 00:45:31 CET 2021

The error says

 unable to load shared object '/Library/Frameworks/R.framework/Versions/4.1/Resources/library/openssl/libs/openssl.so':

so it's having trouble loading the openssl R package. There are installation instructions for this package at


(I found this from the CRAN package landing page https://cran.r-project.org/package=openssl 'URL' field) There it says that to install on macOS you need to

  brew install openssl

In general the strategy is to start at the first ERROR that occurs, and carefully try to 'decode' what it is trying to tell you.

The problem you are running into is that the 'release' version of macOS CRAN packages are generally available as pre-built 'binary' packages, so you don't have to do anything special to make them work. The 'devel' version of macOS CRAN packages are not available for binary installation, so you have to have additional system dependencies like libgit2 and openssl also installed.


On 2/11/21, 6:06 PM, "Bioc-devel on behalf of Krithika Bhuvaneshwar" <bioc-devel-bounces using r-project.org on behalf of kb472 using georgetown.edu> wrote:

    Hi Nitesh,

    Thanks for your reply.

    I managed to get libgit2 installed. But having trouble with its other
    dependencies - ‘gert’

    Please see attached txt which is a full information of the error.

    Do you have an installation of R 4.1 that is more stable where devtools is
    working ? If yes, are you able to share that with me ?


    On Thu, Feb 11, 2021 at 12:03 PM Nitesh Turaga <nturaga.bioc using gmail.com>

    > Hi,
    > Could you provide more information about the error you face with `brew
    > install libgit2` ?? Without knowing what error message you see, it's hard
    > to speculate about why devtools or gert didn’t work.
    > Best,
    > On 2/11/21, 12:00 AM, "Bioc-devel on behalf of Krithika Bhuvaneshwar" <
    > bioc-devel-bounces using r-project.org on behalf of kb472 using georgetown.edu> wrote:
    >     Hello,
    >     We are the package maintainers of the CINdex package. Our package is
    > giving
    >     build errors and we are investigating why. I'm currently working on
    > setting
    >     up the environment so I can replicate the error.
    >     I have a MacOS High Sierra. Here is what I did:
    >     * downloaded R 4.1 from  https://mac.r-project.org/ and
    >     * Got the latest  BioC 3.13 using BiocManager::install(version =
    > "devel")
    >     * When I tried *install.packages("devtools")*, it said
    >     *"Package which is only available in source form, and may need
    > compilation
    >     of **C/C++/Fortran: ‘gert’*
    >     So Then I did *install.packages("devtools")*
    >     It gave me an error saying
    >     *"Configuration failed to find libgit2 library." Try installing: brew:
    >     libgit2 (MacOS)*
    >     I have tried installing libgit2 using both brew and within R. Neither
    >     worked. So at this point, I'm unable to install devtools . And without
    >     devtools, Check And Build are not working
    >     Has anyone else encountered this issue, please advise on how to fix
    > this.
    >     Thanks,
    >     Krithika
    >         [[alternative HTML version deleted]]
    >     _______________________________________________
    >     Bioc-devel using r-project.org mailing list
    >     https://stat.ethz.ch/mailman/listinfo/bioc-devel

More information about the Bioc-devel mailing list