[Bioc-devel] Cannot reproduce "TeX capacity exceeded" error on build hosts (package messina)

Mark Pinese MP|ne@e @end|ng |rom cc|@@org@@u
Wed Apr 21 03:17:38 CEST 2021

Hi all,

My package messina has recently started failing on all build platforms, eg https://master.bioconductor.org/checkResults/3.12/bioc-LATEST/messina/malbec1-buildsrc.html. This seems due to a "TeX capacity exceeded" error, though I suspect that something upstream is the true culprit.

To debug I have tried to reproduce this locally with BioC 3.12 on R 4.0.3 (both clean installs), but I cannot reproduce the problem. Locally the build works without issues for me:

source ~/.Renv_biocbuild 
R CMD build ~/repos/messina/
* checking for file ‘~repos/messina/DESCRIPTION’ ... OK
* preparing ‘messina’:
* checking DESCRIPTION meta-information ... OK
* cleaning src
* installing the package to build vignettes
* creating vignettes ... OK
* cleaning src
* checking for LF line-endings in source and make files and shell scripts
* checking for empty or unneeded directories
* looking to see if a ‘data/datalist’ file should be added
* building ‘messina_1.23.1.tar.gz’

Can anyone offer suggestions on how to reproduce the error as seen on the build environments? Something like a docker image matching the build environments would be ideal. I tried the image bioconductor/bioconductor_docker:devel, but I needed to install quite a few build dependencies, so I suspect this image doesn't match the build envs.

Many thanks,


Mark Pinese

Senior Bioinformatics Research Officer
Conjoint Senior Lecturer, School of Women’s and Children’s Health, UNSW Medicine
NHMRC Emerging Leadership Fellow

Children's Cancer Institute
Lowy Cancer Research Centre, UNSW Australia
PO Box 81 Randwick 2031 Australia

E: MPinese using ccia.org.au  |  W: www.ccia.org.au 

More information about the Bioc-devel mailing list