[Bioc-devel] R CMD build error for 3.10 (but not 3.11)

L Rutter ||nd@@y@nnerutter @end|ng |rom gm@||@com
Tue Feb 25 07:55:45 CET 2020

Dear Lori:

Thanks for the suggestions. I tried to follow the linked instructions on
February 4 and February 9, but was unsuccessful both times (i.e. did not
see the changes pushed to the release branch). I tried following the
instructions again today. I notice that when I issue the command:

git merge upstream/master

I receive the message:

merge: upstream/master - not something we can merge

So, I clicked on the "Sync existing repositories" tab and checked that the
instructions there were working. After adding the upstream branch as

git remote add upstream git using git.bioconductor.org:packages/bigPint.git

When I then try to fetch all (git fetch --all), I receive the following

Fetching origin
Fetching upstream
FATAL: R any packages/bigpint lrutter DENIED by fallthru
(or you mis-spelled the reponame)
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
error: Could not fetch upstream

I changed my GitHub userName about one year ago from "lrutter" to
"lindsayrutter". By doing "git remote -v", I can see that my origin
branches are correctly at "lindsayrutter", but I am unable to see about my
upstream branches on git.bioconductor. This is my output from "git remote

origin https://github.com/lindsayrutter/bigPint (fetch)
origin https://github.com/lindsayrutter/bigPint (push)
upstream git using git.bioconductor.org:packages/bigpint.git (fetch)
upstream git using git.bioconductor.org:packages/bigpint.git (push)

Do you have any advice on how I can fix this issue with fetch upstream
possibly expecting my older userName? Thank you for sharing advice.


2020年2月3日(月) 21:54 Shepherd, Lori <Lori.Shepherd using roswellpark.org>:

> It looks like you only pushed changes to the master branch which is our
> devel branch (3.11).
> Please see the instructions for
> http://bioconductor.org/developers/how-to/git/bug-fix-in-release-and-devel/
> where RELEASE_X_Y   would be RELEASE_3_10  for pushing changes to the
> release 3.10 branch.
> Lori Shepherd
> Bioconductor Core Team
> Roswell Park Comprehensive Cancer Center
> Department of Biostatistics & Bioinformatics
> Elm & Carlton Streets
> Buffalo, New York 14263
> ------------------------------
> *From:* Bioc-devel <bioc-devel-bounces using r-project.org> on behalf of L
> Rutter <lindsayannerutter using gmail.com>
> *Sent:* Saturday, February 1, 2020 4:18 AM
> *To:* bioc-devel using r-project.org <bioc-devel using r-project.org>
> *Subject:* [Bioc-devel] R CMD build error for 3.10 (but not 3.11)
> Dear all:
> I have been receiving messages that my Bionconductor package bigPint is
> producing errors on 'R CMD build' on malbec1. I believe I discovered the
> source of the error, fixed it, and pushed changes to my GitHub account (
> github.com/lindsayrutter) on December 10, 2019. I continued to receive
> this
> error notification and was advised to ensure I had pushed the changes to
> Bioconductor. I pushed changes following these instructions (
> http://bioconductor.org/developers/how-to/git/) on January 4, 2020. I am
> still receiving notifications that my package produces errors on 'R CMD
> build' on malbec1 (
> https://master.bioconductor.org/checkResults/3.10/bioc-LATEST/bigPint/malbec1-buildsrc.html
> ).
> However, it seems my package is no longer failing daily build reports for
> version 3.11 as of January 4, 2020 (
> http://bioconductor.org/checkResults/3.11/bioc-LATEST/).
> I am seeking advice on what a maintainer should try in this situation? Is
> it possible my changes were only recognized in version 3.11 but not version
> 3.10? Thank you for any advice you may have!
> Sincerely,
> L. Rutter
>         [[alternative HTML version deleted]]
> _______________________________________________
> Bioc-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/bioc-devel
> This email message may contain legally privileged and/or confidential
> information. If you are not the intended recipient(s), or the employee or
> agent responsible for the delivery of this message to the intended
> recipient(s), you are hereby notified that any disclosure, copying,
> distribution, or use of this email message is prohibited. If you have
> received this message in error, please notify the sender immediately by
> e-mail and delete this email message from your computer. Thank you.

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list