[Bioc-devel] Cannot reproduce a regionReport 1.21.7 error on the Bioc 3.11 Linux builder

Leonardo Collado Torres |co||@dotor @end|ng |rom gm@||@com
Fri Apr 24 04:03:04 CEST 2020


I went to google again and maybe
https://github.com/phw/peek/issues/112#issuecomment-296690302 is the
answer? It would require someone with access to the Linux builder to
check this particular ImageMagick config XML file.

I had linked to this thread earlier
though back then I mentioned that it could be a disk space issue. That
was before the more recent thread about that ended with ggbio being
bumpted to 1.35.2 (for which using Bioconductor's devel docker
revealed the problem).

I also just asked on Twitter
https://twitter.com/fellgernon/status/1253502433231343617?s=20 to see
if anyone has seen a similar error.


On Thu, Apr 23, 2020 at 9:36 PM Leonardo Collado Torres
<lcolladotor using gmail.com> wrote:
> Hi Bioc-devel,
> I'm having trouble with my regionReport package on the Bioc-devel
> (3.11) Linux builds. Two weeks ago, using the Bioconductor devel
> docker I was able to reproduce an error that was solved by ggbio
> bumping their version number to 1.35.2 as described in [1]. I've tried
> my best to reproduce the error shown at [2] which is:
> Quitting from lines 224-229 (basicExploration.Rmd)
> Error: processing vignette 'regionReport.Rmd' failed with diagnostics:
> R: unable to get registry ID `cache:hosts' @
> error/registry.c/GetImageRegistry/202
> Recently [3], I bumped the regionReport version to 1.21.7 where I
> explicitly asked for ggbio 1.35.2 to be available. I suspected that
> the Linux builder still had version ggbio 1.35.1 installed. But that
> did not resolve the issue as the current build report is for
> regionReport version 1.21.7 and there's no error about ggbio 1.21.7
> not being available. Hm... the required versions for the dependencies
> does get checked at R CMD build (or even install), right?
> At [4] you can see that regionReport 1.21.7 can be successfully
> checked against Bioconductor devel's docker. This uses GitHub actions
> that has 7 GB of RAM available [5]. The memory resources (7GB vs 2.5
> GB? [6]), disk space (14 GB vs ?) and some system dependencies are the
> only differences I can think of (installed through [7], none seem to
> me to be related from what I see at [8]) besides the Linux builder
> differences vs the Bioconductor devel docker (dunno what they are).
> If you have any suggestions, please let me know.
> Best,
> Leo
> [1] https://stat.ethz.ch/pipermail/bioc-devel/2020-April/016538.html
> [2] https://master.bioconductor.org/checkResults/3.11/bioc-LATEST/regionReport/malbec2-buildsrc.html
> [3] https://github.com/leekgroup/regionReport/commit/5e7d956f71011f8551f2431f5af0e212d04be9f1
> [4] https://github.com/leekgroup/regionReport/runs/604161822?check_suite_focus=true#step:8:98
> [5] https://help.github.com/en/actions/reference/virtual-environments-for-github-hosted-runners#supported-runners-and-hardware-resources
> [6] https://github.com/Bioconductor/Contributions/issues/1389#issuecomment-605024369
> 2.5 GB is used for the 32-bit windows Single Package Builder.
> [7] https://github.com/leekgroup/regionReport/runs/604161822?check_suite_focus=true#step:6:2
> [8] https://github.com/leekgroup/regionReport/runs/604161822?check_suite_focus=true#step:6:167
> Leonardo Collado Torres, Ph. D., Research Scientist
> Lieber Institute for Brain Development
> 855 N Wolfe St, Suite 300
> Baltimore, MD 21205
> http://lcolladotor.github.io

More information about the Bioc-devel mailing list