[Bioc-devel] HDF5Array failure on windows

McDavid, Andrew Andrew_Mcd@v|d @end|ng |rom URMC@Roche@ter@edu
Wed Apr 8 17:27:27 CEST 2020

For what it's worth, I have been getting seemingly the same error from HDF5Array, only on windows, on the package builder: https://master.bioconductor.org/checkResults/3.11/bioc-LATEST/MAST/tokay2-buildsrc.html

I have been hoping it will magically go away, as I do not have access to any windows systems to troubleshoot.  Maybe my wish will be come true :-)?

Andrew McDavid
Biostatistics and Computational Biology
Office: SRB 4.206 Ph: 585.275.5983

Hi Kasper, Martin,

About bsseq's timeout: An important recent change to
DelayedArray/HDF5Array is that, starting with DelayedArray 0.13.8,
nothing in these packages uses parallel evaluation **by default**.
Concretely this means that getAutoBPPARAM() now returns NULL on a fresh
session instead of one of the parallelization backends defined in
BiocParallel (e.g. MulticoreParam on Linux/Mac, SnowParam on Windows).
This could slow down some code in bsseq or other packages that were
benefiting from the automatic parallel evaluation. Now it's the
responsibility of the user to set the parallelization backend (with
setAutoBPPARAM) if they wish things like matrix multiplication, rowsum()
or rowSums() use parallel evaluation again.

Also BiocParallel has been moved from Depends to Suggests.

About bsseq error on Windows: That seems indeed to be related to the
HDF5Array error on the same platform. The unit tests in bsseq and
HDF5Array both fail with the same error ("HDF5 dataset
'./.HDF5ArrayAUTO00014_dimnames/2' does not exist"). I'll take a look.
What's puzzling is that we see this error on both Windows archs for
bsseq (i.e. on 64-bit and 32-bit) while we only see it on 64-bit Windows
for HDF5Array. This suggests something nasty and hard to troubleshoot..


	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list