[Bioc-devel] Problems with converting GPos to GRanges.

Charles Plessy ch@r|e@@p|e@@y @end|ng |rom o|@t@jp
Fri Sep 13 06:29:58 CEST 2019


I am trying to make the CAGEr package (1.27.2) pass its regression 
tests, and I am still struggling with the refactoring of GPos to 
UnstitchedGPos and StitchedGPos in the devel branch of Bioconductor...

Currently, my problem is with the following command:


CTSScoordinatesGR(exampleCAGEexp) returns a GPos object of transcription 
start sites, that I want to transform in promoter ranges.

While it worked in the past, I now have the following error:

Error in (function (classes, fdef, mtable)  :
   unable to find an inherited method for function ‘update_ranges’ for 
signature ‘"UnstitchedIPos"’

I tried the same command with the gpos1a and gpos1b example objects from 
the GPos manual page, and they do not trigger the error.

Further inspection showed me that 
GRanges(CTSScoordinatesGR(exampleCAGEexp)) returns a GRanges object 
where the ranges are still in UnstitchedIPos class, while in the case of 
gpos1a and gpos1b they has been converted.

I do not know how to deal with that problem and I would appreciate some 

Have a nice day,


Charles Plessy - - ~ ~ ~ ~ ~ ~~~~ ~ ~ ~ ~ ~ - - charles.plessy using oist.jp
Okinawa  Institute  of  Science  and  Technology  Graduate  University
Staff scientist in the Luscombe Unit - ~ - https://groups.oist.jp/grsu
Toots from work - ~ ~~ ~ - https://mastodon.technology/@charles_plessy

More information about the Bioc-devel mailing list