[Bioc-devel] Cannot update my development package to Bioconductor

cstrato c@tr@to @ending from @on@@t
Mon May 14 20:48:54 CEST 2018

Dear GIT experts,

On Saturday I wanted to update my development package to xps_1.41.1, 
however until now it was not updated in the 'Multiple platform 
build/check report' although I could confirm the changes with Firefox: 

For this reason I tried today to update my development package to 

I did follow exactly the guidelines of:

Here are the results:

$ cd /Volumes/T3Data/CRAN/GIT/xps

$ git remote -v
origin  git at github.com:cstrato/xps.git (fetch)
origin  git at github.com:cstrato/xps.git (push)
upstream        git at git.bioconductor.org:packages/xps (fetch)
upstream        git at git.bioconductor.org:packages/xps (push)

$ git checkout master
Already on 'master'
Your branch is up-to-date with 'origin/master'.

$ git add -v DESCRIPTION

$ git add -v NEWS
add 'NEWS'

$ git commit -m "update for NEWS"
[master cf326be] update for NEWS
  2 files changed, 6 insertions(+), 1 deletion(-)

$ git push origin master
Enter passphrase for key '/Users/cstrato/.ssh/id_rsa':
Counting objects: 4, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 375 bytes | 0 bytes/s, done.
Total 4 (delta 3), reused 0 (delta 0)
remote: Resolving deltas: 100% (3/3), completed with 3 local objects.
To github.com:cstrato/xps.git
    7616d60..cf326be  master -> master

$ git push upstream master
Enter passphrase for key '/Users/cstrato/.ssh/id_rsa':
To git.bioconductor.org:packages/xps
  ! [rejected]        master -> master (fetch first)
error: failed to push some refs to 'git at git.bioconductor.org:packages/xps'
hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

# check in Firefox

For some reason I get the same error as on Saturday when trying to do:
$ git push upstream master

Can you tell me what may be the reason for this error?
('git push --help' was not very helpful for me)

Best regards,
C.h.r.i.s.t.i.a.n   S.t.r.a.t.o.w.a
V.i.e.n.n.a           A.u.s.t.r.i.a
e.m.a.i.l:        cstrato at aon.at

More information about the Bioc-devel mailing list