[Bioc-devel] error from biocLite on OSX with R-devel / Bioc-devel

Levi Waldron lwaldron.research at gmail.com
Mon Jan 30 05:25:13 CET 2017

Not sure anyone will be able to help with this, but I can no longer install
packages from bioc-devel using a current R-devel and biocLite() on my
OSX Yosemite 10.10.5. I can still install from the command line `R CMD
INSTALL` and `install.packages()`. Here is the error - the package lazyeval
is just an example of a commonly used package from CRAN so I can show that
install.packages works, but it seems to happen for all CRAN, Bioconductor,
or Github packages. I don't have any problems when using R 3.3.2 patched +
Bioc 3.4.

> biocLite("lazyeval")

BioC_mirror: https://bioconductor.org

Using Bioconductor 3.5 (BiocInstaller 1.25.3), R Under development

  (2017-01-26 r72035).

Installing package(s) ‘lazyeval’

*Error in readRDS(dest) : error reading from connection*

Note that the problem isn't there with `install.packages()`:

> install.packages("lazyeval")  ##successful install

Following some advice from stackoverflow
<http://stackoverflow.com/questions/6473831/readrdsfile-in-r> and rstudio
people who've had the same error in R, I tried starting from a fresh
install (and didn't see any zero-size rds files in my R library), and am
still having the problem *only* when using biocLite (not install.packages
or R CMD INSTALL).  Just to show this is a fresh installation (I have only
installed R-devel from https://r.research.att.com/, then done `> source("

> dir(.libPaths())

 [1] "AnnotationDbi" "base"          "BH"            "Biobase"

 [5] "BiocGenerics"  "BiocInstaller" "boot"          "class"

 [9] "cluster"       "codetools"     "compiler"      "datasets"

[13] "DBI"           "digest"        "foreign"       "graphics"

[17] "grDevices"     "grid"          "IRanges"       "KernSmooth"

[21] "lattice"       "lazyeval"      "MASS"          "Matrix"

[25] "memoise"       "methods"       "mgcv"          "nlme"

[29] "nnet"          "parallel"      "plogr"         "Rcpp"

[33] "rpart"         "RSQLite"       "S4Vectors"     "spatial"

[37] "splines"       "stats"         "stats4"        "survival"

[41] "tcltk"         "tools"         "translations"  "utils"

One other strange thing I've noticed - using my primary user account I got
one good call to biocLite after the fresh install of R-devel, then all
subsequent calls produced this error. The good call installed Bioconductor
in a system directory for all users. Then starting as another user without
write access to the system package library, that user got one good call
which created a user directory library, and I could use to run
biocLite("lazyeval") locally, but then subsequent calls to biocLite failed
for that user too.

biocValid() and session info:

> biocValid()

[1] TRUE

> sessionInfo()

R Under development (unstable) (2017-01-26 r72035)

Platform: x86_64-apple-darwin13.4.0 (64-bit)

Running under: OS X Yosemite 10.10.5


[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:

[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:

[1] BiocInstaller_1.25.3

loaded via a namespace (and not attached):

[1] compiler_3.4.0 tools_3.4.0    tcltk_3.4.0


	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list