[Bioc-devel] BiocStyle::doc_date() not found when testing on Travis via metacran/r-builder

Leonardo Collado Torres lcollado at jhu.edu
Tue Nov 3 05:07:48 CET 2015

I was going to ask this as an issue at the Bioconductor/BiocStyle
repo, but the issue tracker is disabled.
I ran into a bug which I'm not sure where it comes from. It happens
during R CMD build using BiocStyle to generate an html vignette.
For example, here is one such error:
Quitting from lines 2-17 (derfinderHelper.Rmd)
Error: processing vignette 'derfinderHelper.Rmd' failed with diagnostics:
could not find function "doc_date"
Execution halted
doc_date comes from the yaml for the html vignette in which I use:
date: "r doc_date()"
The full log for this error message is at:
I used BiocStyle version 1.8.0 (see
and metacran/r-builder with the following Travis configuration file
I got the same error with other packages but wasn't able to reproduce
it locally. I tried with pandoc 1.13.1 instead of 1.12.3 and it didn't
work either on Travis (using metacran/r-builder). However, switching
to R Travis v2 (the one with docs on the Travis website) works.
Here is a full log of a case that works
using the same BiocStyle version and the following Travis config file
It's also the same R version (3.2.2).
I think that something about the R version in metacran/r-builder could
be the problem. Before I report this to metacran/r-builder, I was
wondering if the BiocStyle maintainers had come up with this type of
error before or have any clues on how to resolve it.
PS I'd like this to work with metacran/r-builder given the R-devel
issue with R Travis v2. Although it seems like docker support is on
the way https://github.com/kasperdanielhansen/bsseq/issues/5

More information about the Bioc-devel mailing list