[Bioc-devel] Build/check questions

Herve Pages hpages at fhcrc.org
Fri Sep 22 02:08:03 CEST 2006

James MacDonald wrote:
> Hi!
> I have two questions about results on the build/check page for release
> 1.9.
> First, for my affycoretools package, the build on Solaris says OK, but
> in the output I see this line:
>  creating vignettes ...Segmentation Fault - core dumped
>  OK
> I suppose the build page *should* say OK, since this step returned an
> OK. However, I am pretty sure a segfault is A Bad Thing. Maybe I should
> ask on R-devel why this returns an OK? Should I expect that the build
> page would be able to return something other than OK in this situation?

Hi Jim,

Since this is a bug in 'R CMD build', IMHO yes, it would be worth
reporting the problem on R-devel. I've already reported it
back in May and never got an answer but may be you'll be more
lucky than I was. A workaround for now could be to add some code
to our build system to parse the output returned by 'R CMD build'
but I never really took the time to implement this :-/

> Second, on all three Linux boxes (and on mine as well, but not on
> windows), there is a cryptic warning that I don't understand:
> * checking whether the name space can be loaded with stated
> dependencies ... WARNING
> Loading required package: methods
> Error in if (mustFind) stop(gettextf("no generic function found for
> \"%s\"",  : 
> 	argument is not interpretable as logical
> In addition: Warning message:
> the condition has length > 1 and only the first element will be used
> in: if (mustFind) stop(gettextf("no generic function found for \"%s\"", 
> Execution halted
> A namespace must be able to be loaded with just the base namespace
> loaded:
> otherwise if the namespace gets loaded by a saved object, the session
> will
> be unable to start.
> Probably some imports need to be declared in the NAMESPACE file.
> Is there a reasonable way to track down what imports are missing?

I agree that this kind of message could be more usefull.
The problem seems to occur when the GOstats NAMESPACE
is imported into your NAMESPACE (I've tried to remove GOstats
from import(annaffy, GOstats, biomaRt) in your NAMESPACE and
didn't get the warning anymore).
The check result for the GOstats package itself shows the
same error.
I've done been further and don't know what's wrong with the
GOstats NAMESPACE. Are there some imports that need to be
declared here?

BTW, something that could be reported on R-devel too is that
the "checking whether the name space can be loaded with stated
dependencies" at least says for which NAMESPACE loading
the warning is currently issued. Imagine a situation where we
have to track down 20 levels of nested NAMESPACE importation :-/


Hervé Pagès
E-mail: hpages at fhcrc.org
 Phone: (206) 667-5791
   Fax: (206) 667-1319

More information about the Bioc-devel mailing list