[R-sig-ME] lme4

Phillip Alday me @end|ng |rom ph||||p@|d@y@com
Mon May 10 17:23:23 CEST 2021

Hi Emanuele,

It helps us a little bit if you tell us what the solutions you tried
actually were. We don't know what websites you looked at.

It looks like you're on the new Apple silicon. Unfortunately, Apple
there isn't a release of gfortran for that, which has created a lot of
problems for numerical and statistical computing. For now, I would
recommend running R for x86-64 via Rosetta.


On 10/5/21 4:20 pm, emanuele favaron wrote:
> Good afternoon,
> I'm working on R studio Version 1.4.1625 in MacOs Big Sur 11.2.2.
> Trying to load library(lme4) I get this answer:
> Error: package or namespace load failed for ‘lme4’ in dyn.load(file,
> DLLpath = DLLpath, ...):
>  unable to load shared object
> '/Library/Frameworks/R.framework/Versions/4.1-arm64/Resources/library/statmod/libs/statmod.so':
> dlopen(/Library/Frameworks/R.framework/Versions/4.1-arm64/Resources/library/statmod/libs/statmod.so,
> 6): Library not loaded: /opt/R/arm64/gfortran/lib/libgfortran.5.dylib
>   Referenced from:
> /Library/Frameworks/R.framework/Versions/4.1-arm64/Resources/library/statmod/libs/statmod.so
>   Reason: image not found
> I already tried all the possible solutions suggested in some websites but
> they don't work. How can I solve this problem?
> Thanks in advance
> Emanuele
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-sig-mixed-models using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-sig-mixed-models

More information about the R-sig-mixed-models mailing list