[R-sig-ME] glmmADMB error: Invalid index for array

Moore, Peggy peggy_moore at usgs.gov
Tue Feb 16 22:28:47 CET 2016

As a follow-up to a response I sent earlier to day, I wanted to point out
that our statistician tried fitting the same model to the Owls data with
glmmADMB and is seeing the same pattern. We both tried model fits that were
really pared down, but received the same errors as long as mcmc=TRUE. After
it performed the Newton-Raphson steps when run from the cmd prompt, it
produced the error of an 'invalid index for array.' With two different data
sets and three different models, the error always indicates, if I'm reading
it correctly, that the index is one value greater than appropriate for the
array (i.e., 9 if array is [1, 8] or 19 if array is [1, 18].
Our statistician is not co-located with me - she is 150 miles away - but we
are both on US Geological Survey machines, so we could have settings in
common. I see no trouble with writing files to the save.dir location,
however, such as the .dat, .pin, .std, and .exe files and 40 more. Is there
anything else you can suggest?

Peggy Moore
U.S. Geological Survey
Western Ecological Research Center
Yosemite Field Station - El Portal Office
5083 Foresta Rd, El Portal, CA 95318
peggy_moore at usgs.gov
209.379.1309 (Mon, Tue, Fri)
209.617.7775 (Wed, Thur)

	[[alternative HTML version deleted]]

More information about the R-sig-mixed-models mailing list