[R-sig-ME] lmer formula syntax?

Ben Bolker bbolker at gmail.com
Wed Feb 16 04:28:35 CET 2011

Hash: SHA1

On 11-02-15 10:24 PM, Dominick Samperi wrote:
> On Wed, Feb 2, 2011 at 4:55 PM, Douglas Bates <bates at stat.wisc.edu> wrote:
>> On Wed, Feb 2, 2011 at 3:43 PM, Colin Wahl <biowahl at gmail.com> wrote:
>>> I too have found the Bate's book draft helpful, but I have not been able to
>>> get the lme4a package installed. The best description I have found to do so
>>> is:
>>> http://kmyu.wordpress.com/2010/12/04/installing-lme4a-in-r-mac-osx-10-6-4/
>>> I'm understanding that the lme4a package is dependent on a number of
>>> packages: RcppArmadillo, minqa and MatrixModels (available on CRAN
>>> respositories) and Rcpp version or later (which is not; version
>>> 0.8.6 is).
>> (Actually it doesn't depend on RcppArmadillo).
>> You must be using Mac OS X.  If you check at
>> cran.r-project.org/web/packages/Rcpp you will see that the Windows
>> binary and the source code packages are at version 0.9.0 but the Mac
>> OS X version is only at 0.8.6, which is rather old.  I'm not sure what
>> the problem is as Romain develops on a Mac OS X system and he can't
>> reproduce the error.
>> However, you don't really need lme4a for most of the examples in the
>> book.  The lme4 package can't handle the profile-related material, but
>> the rest of the examples should be okay.  The output looks slightly
>> different but the parameter estimates should be essentially the same.
> FYI, I just tried the current R-Forge version of lme4a using Rcpp 0.9.0
> and there is a problem in the print function when the first argument x
> is an image() call. This happens while trying the script Ch4.R.
> I realize this is work in progress, and I tried to use lme4 first, but there
> was a problem with that.
> Is there a recommended snapshot/version set for minqa, MatrixModels,
> lme4a, etc. that will run the chapter scripts?
> Thanks,
> Dominick

 Have you tried the lme4a version posted at
<http://lme4.r-forge.r-project.org> (see the last paragraph on that
page)?  If that doesn't work, please let me know and I will try to fix
it / resolve dependencies by making them available.

  Ben Bolker
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the R-sig-mixed-models mailing list