[R-sig-ME] lme4 and Matrix from R-forge

Steven McKinney smckinney at bccrc.ca
Fri May 2 19:56:55 CEST 2008

Just curious, maybe Simon Urbanek will know,
but why is version 2.6 showing in the R.framework
path when you are running R 2.7.0?

> /Library/Frameworks/R.framework/Versions/2.6/Resources/lib/libRlapack.dylib

Steven McKinney

-----Original Message-----
From: r-sig-mixed-models-bounces at r-project.org on behalf of Douglas Bates
Sent: Fri 5/2/2008 8:49 AM
To: John Maindonald
Cc: R Mixed Models
Subject: Re: [R-sig-ME] lme4 and Matrix from R-forge
It seems to me that those messages are coming from the attempt to load
the Matrix package.  It looks a bit peculiar in that the compiled code
for the Matrix package is in the file Matrix.so and it is linked
against libRlapack.dylib.  That seems inconsistent.

If you have the necessary tools installed then I would recommend
installing the Matrix package from the source file.  I believe that
the version on CRAN and the source version on R-forge should both be

On Fri, May 2, 2008 at 7:34 AM, John Maindonald
<john.maindonald at anu.edu.au> wrote:
> I am wondering if there is a problem with attaching the latest lme4 and
> Matrix from R-forge.
>> library(lme4)
> Loading required package: Matrix
> Loading required package: lattice
> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>  unable to load shared library
> '/Library/Frameworks/R.framework/Resources/library/Matrix/libs/i386/Matrix.so':
>  dlopen(/Library/Frameworks/R.framework/Resources/library/Matrix/libs/i386/Matrix.so,
> 6): Library not loaded:
> /Library/Frameworks/R.framework/Versions/2.6/Resources/lib/libRlapack.dylib
>  Referenced from:
> /Library/Frameworks/R.framework/Resources/library/Matrix/libs/i386/Matrix.so
>  Reason: image not found
> Error: package 'Matrix' could not be loaded
>> sessionInfo()
> R version 2.7.0 Patched (2008-05-01 r45578)
> i386-apple-darwin8.10.1
> locale:
> en_AU.UTF-8/en_AU.UTF-8/C/C/en_AU.UTF-8/en_AU.UTF-8
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
> other attached packages:
> [1] lattice_0.17-6
> loaded via a namespace (and not attached):
> [1] grid_2.7.0
> It is possible I have corrupted my installation; I first tried to install
> Matrix_0.999375-10.tgz with the CRAN version of lme4 installed,
> then tried to go back to the CRAN version of Matrix.  My version
> of lme4 is lme4_0.999375-14.tgz
> John Maindonald             email: john.maindonald at anu.edu.au
> phone : +61 2 (6125)3473    fax  : +61 2(6125)5549
> Centre for Mathematics & Its Applications, Room 1194,
> John Dedman Mathematical Sciences Building (Building 27)
> Australian National University, Canberra ACT 0200.
> _______________________________________________
> R-sig-mixed-models at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-sig-mixed-models

R-sig-mixed-models at r-project.org mailing list

More information about the R-sig-mixed-models mailing list