[R-SIG-Mac] Setting _R_CHECK_DEPENDS_ONLY_=true

John Fox j|ox @end|ng |rom mcm@@ter@c@
Sun May 1 15:36:06 CEST 2022

Dear Roger,

I raised a similar question on R-SIG-Mac last week, and these warnings 
are not a problem with your package. See in particular Brian Ripley's 
response at 
<https://stat.ethz.ch/pipermail/r-sig-mac/2022-April/014411.html> and 
the rest of the thread.


On 2022-05-01 8:38 a.m., Koenker, Roger W wrote:
> Ok,  this worked as I expected so _R_CHECK_DEPENDS_ONLY_=true  now reveals the same problem that CRAN detected, which was easily fixed.  But I’m left with a NOTE with a large number of HTML warnings that begin with:
> * checking HTML version of manual ... NOTE
> Found the following problems:
> Bosco.Rd:4:1: Warning: <link> inserting "type" attribute
> Bosco.Rd:12:1: Warning: <script> proprietary attribute "onload"
> Bosco.Rd:12:1: Warning: <script> inserting "type” reattribute
> Are these deadly from a CRAN perspective?  And if so, any hints about how to fix them?  Googling only produced the following thread:   https://github.com/htacg/tidy-html5/issues/377
>> On Apr 30, 2022, at 5:17 PM, Koenker, Roger W <rkoenker using illinois.edu> wrote:
>> I’m trying to enable  _R_CHECK_DEPENDS_ONLY_=true  option for R CMD check —as-cran  on a
>> R version 4.1.3 (2022-03-10) -- "One Push-Up”  on an Intel mac mini.
>>> .libPaths()
>> [1] "/Library/Frameworks/R.framework/Versions/4.1/Resources/library”
>> I’ve tried putting  _R_CHECK_DEPENDS_ONLY_=true in ~/.R/check.Renviron
>> and also tried (in bash) export _R_CHECK_DEPENDS_ONLY_=true in bash prior to R CMD check, but I can’t replicate the errors found with CRAN checking, which is becoming embarrassing.
>> Kurt offered the following Zen koan:
>>> The mechanism only works when you only have the base/recommended
>>> packages in .Library, and the rest in a separate user library. Which
>>> needs a .libPaths() of lenght at least two …
>> When I do:
>>> Sys.getenv("R_LIBS_USER")
>> [1] "~/Library/R/x86_64/4.1/library”
>> But as the R Installation and Administration manual says this is only used if it exists, which it doesn’t in my case.  I now interpret this to mean that I should install 4.2, create this directory and reinstall packages so that they appear there rather than under the RHOME directory.   If someone could confirm this or suggest an alternative strategy I’d be most grateful.
>> Roger
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac using r-project.org
>> https://urldefense.com/v3/__https://stat.ethz.ch/mailman/listinfo/r-sig-mac__;!!DZ3fjg!79fWEQZV39wadd_f0tOjMxJ6Vu-Np3mrdCl2PraiyD_VFph_KJidVXoQDauIM5QKsRPMeEALDlugu2U-_MgXdNu3$
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac using r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
John Fox, Professor Emeritus
McMaster University
Hamilton, Ontario, Canada
web: https://socialsciences.mcmaster.ca/jfox/

More information about the R-SIG-Mac mailing list