[R-SIG-Mac] more rgl problems

Duncan Murdoch murdoch@dunc@n @end|ng |rom gm@||@com
Thu Feb 18 12:30:40 CET 2021

On 18/02/2021 6:14 a.m., Peter West wrote:
> Yes, I went through that process. I have no org.xquartz.* files in 
> /Library Launch* now.

If you run x11(), does it cause the same issue?

What about not starting R at all, and just running some X11 app like 
xclock from the terminal?

Duncan Murdoch

>> On 18 Feb 2021, at 9:08 pm, Duncan Murdoch <murdoch.duncan using gmail.com 
>> <mailto:murdoch.duncan using gmail.com>> wrote:
>> On 17/02/2021 10:13 p.m., Peter West wrote:
>>> And speaking of M1 Silicon:
>>> My XQuartz version is 2.7.11.
>>> Started R 4.0.4.
>>> Stopped R 4.0.4
>>> Started RStudio
>>>> install.packages("rgl")
>>> trying URL 
>>> 'https://cran.rstudio.com/bin/macosx/contrib/4.0/rgl_0.105.13.tgz 
>>> <https://cran.rstudio.com/bin/macosx/contrib/4.0/rgl_0.105.13.tgz>'
>>> Content type 'application/x-gzip' length 6446159 bytes (6.1 MB)
>>> ==================================================
>>> downloaded 6.1 MB
>>> The downloaded binary packages are in
>>> /var/folders/jf/mkyz74311796dl4mxx_7tcx80000gn/T//RtmpflD1wL/downloaded_packages
>>>> library(rgl)
>>> RStudio hangs indefinitely.
>>> My RStudio is at 1.4.1103.
>> That looks a lot like the issue Rich had last week (which I think is 
>> unrelated to the one posted today).  Have you tried the solution I 
>> posted for that?  Here's a copy:
>>> This worked for me to apparently fix my system:
>>> Start with a newly rebooted system.
>>> Uninstall XQuartz by dragging it to the trash.
>>> Look in /Library/LaunchAgents/ for filenames related to xquartz.  I 
>>> had two:  a five year old one called 
>>> org.macosforge.xquartz.startx.plist, and one from around the time I 
>>> installed the XQuartz beta named org.xquartz.startx.plist.  I deleted 
>>> the latter.
>>> Look in /Library/LaunchDaemons/ for similar files.  I deleted one 
>>> with the same name, i.e. org.xquartz.startx.plist, and left an older one.
>>> Reboot the system again, and install XQuartz 2.7.11.  Relogin, and 
>>> things seem fine.
>> I suspect it would be sufficient to just delete the 
>> /Library/LaunchAgents/org.xquartz.startx.plist and 
>> /Library/LaunchDaemons/org.xquartz.startx.plist files and reboot, but 
>> I haven't tried that.
>> Duncan Murdoch

More information about the R-SIG-Mac mailing list