[R-SIG-Mac] catalina humbug

Koenker, Roger W rkoenker @end|ng |rom ||||no|@@edu
Wed Oct 14 13:01:19 CEST 2020


Thanks,  I still have the same error:

In file included from mcmb.c:11:
/usr/local/clang7/include/c++/v1/stdio.h:108:15: fatal error: 'stdio.h' file not found
#include_next <stdio.h>

I didn’t do anything beyond upgrading R and installing fortran 8.2.0, and the CLT 12.2.
but I didn’t remove anything, should I have?  I now see:

yzzy: which clang
yzzy: clang --version
Apple clang version 12.0.0 (clang-1200.0.32.2)
Target: x86_64-apple-darwin19.6.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

The last time I faced this sort of thing James suggested this: 

but the names and locations are somewhat different now, so I’m reluctant to experiment.


> On Oct 14, 2020, at 11:48 AM, Simon Urbanek <simon.urbanek using R-project.org> wrote:
> Roger,
> the error points to an old local clang - did you remove (or move aside) that one? Check your /usr/local - you seem to have some old stuff there that is breaking. That would solve the original issue. You seem to have done a lot after that error, but didn't tell us what happened then… you can't have the same error if you removed it ;) 
> Cheers,
> Simon
>> On Oct 14, 2020, at 10:28 PM, Koenker, Roger W <rkoenker using illinois.edu> wrote:
>> I’ve recently “upgraded” to catalina, and compilation of my quantreg package failed with:
>> In file included from mcmb.c:11:
>> /usr/local/clang7/include/c++/v1/stdio.h:108:15: fatal error: 'stdio.h' file not found
>> #include_next <stdio.h>
>> So I’ve tried the following:
>> 	1.  Upgraded R to 4.0.3
>> 	2.  Upgraded the fortran compiler to 8.2.0 as suggested.
>> 	3.  Attempted to reinstall command line tools with Xcode-select —install.  This fails with
>> 		a popup that says:
>> 		Can’t install the software because it is not currently available from the Software Update server.
>> 	4.  Tried again to reinstall Command line tools 12.2 beta 3 from https://developer.apple.com/download/more/
>> 		which successfully installed, but my stdio.h error persisted.
>> 	5.  Following thread: http://r-sig-mac.29524.n8.nabble.com/R-SIG-Mac-fatal-error-stdio-h-file-not-found-td889.html
>> 		I  looked at:
>> 		yzzy: which clang /usr/bin/clang 
>> 		yzzy: xcode-select -p /Applications/Xcode.app/Contents/Developer 
>> 		yzzy: xcrun --show-sdk-path /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk
>> 		but that didn’t speak to me so further googling led me to:
>> 		https://stackoverflow.com/questions/54557659/r-cant-update-packages-clang-cant-find-head-files
>> 		so lurking in: /Library/Developer/CommandLineTools/usr/include/c++/v1
>> 		is stdio.h, but I’m feeling a bit queasy  at this point and would appreciate some  expert advice.
>> Roger
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac using r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list