[R-SIG-Mac] catalina humbug

Koenker, Roger W rkoenker @end|ng |rom ||||no|@@edu
Wed Oct 14 11:28:06 CEST 2020

I’ve recently “upgraded” to catalina, and compilation of my quantreg package failed with:

In file included from mcmb.c:11:
/usr/local/clang7/include/c++/v1/stdio.h:108:15: fatal error: 'stdio.h' file not found
#include_next <stdio.h>

So I’ve tried the following:

	1.  Upgraded R to 4.0.3
	2.  Upgraded the fortran compiler to 8.2.0 as suggested.
	3.  Attempted to reinstall command line tools with Xcode-select —install.  This fails with
		a popup that says:

  		Can’t install the software because it is not currently available from the Software Update server.
	4.  Tried again to reinstall Command line tools 12.2 beta 3 from https://developer.apple.com/download/more/
		which successfully installed, but my stdio.h error persisted.
	5.  Following thread: http://r-sig-mac.29524.n8.nabble.com/R-SIG-Mac-fatal-error-stdio-h-file-not-found-td889.html
		I  looked at:

		yzzy: which clang /usr/bin/clang 
		yzzy: xcode-select -p /Applications/Xcode.app/Contents/Developer 
		yzzy: xcrun --show-sdk-path /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk

		but that didn’t speak to me so further googling led me to:
		so lurking in: /Library/Developer/CommandLineTools/usr/include/c++/v1
		is stdio.h, but I’m feeling a bit queasy  at this point and would appreciate some  expert advice.


More information about the R-SIG-Mac mailing list