[R-SIG-Mac] Unable to use vecLib BLAS and LAPACK in Mac OS 11.0.1

Anirban Mukherjee @n|rb@n@mukherjee @end|ng |rom gm@||@com
Sun Nov 22 20:50:57 CET 2020

Dear Prof. Ripley,

You are correct. I am using Xcode 12.2. Adding -Wno-implicit-function-declaration enabled the use of the Accelerate (vecLib) BLAS library. The issue is now resolved on on my system. Thank you!


> On 22 Nov 2020, at 2:24 PM, Prof Brian Ripley <ripley using stats.ox.ac.uk> wrote:
> Which version of Xcode/Command Line Tools are you using?  If >= 12 (and perhaps earlier) Apple have set default C options which violate the C99/C11 standard, so you need -Wno-implicit-function-declaration.
> If you have a configure issue, do read and report the relevant parts of config.log file: it probably told you what the problem was (it did for me):
> conftest.c:227:1: error: implicit declaration of function 'dgemm_' is invalid in
> C99 [-Werror,-Wimplicit-function-declaration]
> We will add a further comment to the R-admin manual, but Big Sur has been released for less than a week and a hint was already there ....
> On 22/11/2020 17:33, Anirban Mukherjee wrote:
>> Hi,
>> I am having trouble configuring R to use the vecLib BLAS and LAPACK libraries. I am on Mac OS 11.0.1 and Xcode 12.2. I tried the following options:
>> 1. I downloaded the R binary from CRAN. I tried to follow the instructions at https://cran.r-project.org/bin/macosx/RMacOSX-FAQ.html#Which-BLAS-is-used-and-how-can-it-be-changed_003f to switch the BLAS library. I do not see libRblas.vecLib.dylib in the folder so I cannot switch the BLAS library as given in the FAQ. I also cannot locate libRblas.vecLib.dylib on my system.
>> 2. I tried to compile R from source. I used the following configuration options: --with-blas="-framework Accelerate”  and --with-lapack. I should have all requisite libraries. The compiled R does not use the vecLib BLAS and LAPACK (sessionInfo below signature). During configure, I noticed configure outputted:
>> checking for dgemm_ in -framework Accelerate… no
>> Is that perhaps why configure does not configure the compiled R to use the Accelerate (vecLib) framework? Any suggestions would be very welcome.
>> Thanks,
>> Anirban
>> sessionInfo()
>> R version 4.0.3 Patched (2020-11-20 r79454)
>> Platform: x86_64-apple-darwin20.1.0 (64-bit)
>> Running under: macOS Big Sur 10.16
>> Matrix products: default
>> LAPACK: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRlapack.dylib
>> locale:
>> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods   base
>> loaded via a namespace (and not attached):
>> [1] compiler_4.0.3 tools_4.0.3
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac using r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
> -- 
> Brian D. Ripley,                  ripley using stats.ox.ac.uk
> Emeritus Professor of Applied Statistics, University of Oxford

More information about the R-SIG-Mac mailing list