[R-SIG-Mac] R.app help viewer blank

Ben Tupper btupper at bigelow.org
Tue Sep 19 19:23:10 CEST 2017


I just updated to R 3.4.1 [R.app GUI 1.70 (7375) x86_64-apple-darwin15.6.0] from http://mirror.its.dal.ca/cran/ but have encountered a puzzler.  When I lunch the help viewer like this...


the viewer launches but the page content is blank.  I have also tried he search box in the help viewer as well as the menu selection 'Help > R Help' with the same result.  I have restarted both R.app and the computer without joy. The startup message and output of sessionInfo() are pasted in below.

I can get help successfully from a R session in Terminal.app.  I poked around in the list archives but don't see anything recent on this issue.  

What should I do to enable the help viewer?


R version 3.4.1 (2017-06-30) -- "Single Candle"
Copyright (C) 2017 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwin15.6.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

[R.app GUI 1.70 (7375) x86_64-apple-darwin15.6.0]

> ?data.frame
starting httpd help server ... done

> sessionInfo()
R version 3.4.1 (2017-06-30)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: OS X El Capitan 10.11.6

Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.4.1 tools_3.4.1 

Ben Tupper
Bigelow Laboratory for Ocean Sciences
60 Bigelow Drive, P.O. Box 380
East Boothbay, Maine 04544

Ecocast Reports: http://seascapemodeling.org/ecocast.html
Tick Reports: https://report.bigelow.org/tick/
Jellyfish Reports: https://jellyfish.bigelow.org/jellyfish/

More information about the R-SIG-Mac mailing list