[R-SIG-Mac] Macports installation problem

Daniel Kelley Dan.Kelley at Dal.Ca
Thu Nov 2 10:39:40 CET 2017

This is an exact reposting from 2 weeks ago, and there have been over a dozen replies.


On Oct 16, 2017, at 6:33 AM, John <miaojpm at gmail.com<mailto:miaojpm at gmail.com>> wrote:


  I tried to install Cairo graphics


  and I need to install Macports.

  I tried to install Macports on my Mac OS Sierra 10.12.6, and type "sudo
port install cairo", but it did not respond. I haven't seen any file name
or app called Macports, but one file called "port" which is located at


  How should I do it?



Last login: Sun Oct 15 02:52:49 on console
Johns-MacBook-Pro:~ john$ /opt/local/bin/port ; exit;
MacPorts 2.4.2
Entering shell mode... ("help" for help, "quit" to quit)
[Users/john] > sudo port install cairo
Error: Unrecognized action "port sudo"

[[alternative HTML version deleted]]

R-SIG-Mac mailing list
R-SIG-Mac at r-project.org

	[[alternative HTML version deleted]]

More information about the R-SIG-Mac mailing list