[R-SIG-Mac] R crashes Mac Sierra

Barry M. Lesht blesht at gmail.com
Mon Jan 30 18:56:13 CET 2017

The text below is from an e-mail I tried to post last week, but for some
reason it was not added to the list.  I just experienced another R crash
after attempting to open an existing document.   The nature of the crash is
that the document select window opens but rather than show the list of
available documents, the spinning ball appears and I am unable to interact
with R at all.  I have to force it to quit and then I have to delete the
"saved application state" directory and .Rhistory files.

1.  Brandon:  I was able to reproduce the behavior you describe when
launching R by clicking on an R script.  Indeed using ESC does restore the
session to 'normal.'  I do not generally launch R this way and the crashes
I experience seem to occur when I attempt to open a new script from the
"Open Document" selection in the menu bar.

2.  Christoph:  Have you tried deleting the ~/Library/Saved Application
State/org.R-project.R.savedState/  directory?   I found that I have to
delete this as well as my .Rhistory file to get R to start again after the

3.  Simon:  How does one generate a "crash log."  Is this the "report" that
comes up when "Force Quit" is used to terminate the R session?  Also, I
find that the crashes tend to occur when I try to open a script; I never
get to the point where I source it.  Would the system 'know" about any
"possibly broken packages" before the routine is sourced?

	[[alternative HTML version deleted]]

More information about the R-SIG-Mac mailing list